poj 3311 Hie with the Pie(TSP ,状压dp)

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input
3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0
Sample Output
8
 
 
题意:给你一个图,有n个点,让你把这个图中的所有点都走完,再回到起点的最短路,一个点可以走多次
思路:TSP问题的变形,经典TSP是一个点只能走一次,现在是 可以走多次,那么走多次的意义在哪里呢?
我们设想这样一个场景,当你在a点的时候你可以经过c点到达d距离是5,也可以直接到达d点距离是10,但是c点已经走过了,那么经典的TSP问题就只能直接走到d点,但是一个如果可以走多次那么我们肯定是选择从c点到d点,说到这里大家都可以看出来了,我们走的就是每个点到每个点的最短路,再结合题意n=10,所有我们将所有点跑一边floyd 重新建一个图在跑一边TSP就好了下面上代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 9999999
using namespace std;
int dist[11][11],dp[1<<11][11];
int map[11][11];
int main()
{
	int n;
	while(scanf("%d",&n),n)
	{
		for(int i=0;i<=n;i++)
		{
			for(int j=0;j<=n;j++)
			{
				scanf("%d",&map[i][j]);
			}
		}
		for(int k=0;k<=n;k++){
			for(int i=0;i<=n;i++)
			{
				for(int j=0;j<=n;j++)
				{
					map[i][j]=min(map[i][j],map[i][k]+map[k][j]);	//重新建图 
				}
			}
		}

		memset(dp,inf,sizeof(dp));
		dp[0][0]=0;
		for(int state=0;state<(1<<(n+1));state++)//这里有一个坑点就是 他是从第0号店出发的 所以这里n要+1 
		{
			for(int j=0;j<=n;j++)
			{
			//	if(dp[state][j]==inf) continue;
				for(int k=0;k<=n;k++)
				{
					if((1<<k)&state) continue;
					dp[(1<<k)|state][k]=min(dp[(1<<k)|state][k],dp[state][j]+map[j][k]);
				}
			}
		}
		printf("%d\n",dp[(1<<(n+1))-1][0]);
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值