2015年省赛 B Team Formation【位运算】

11 篇文章 0 订阅
2 篇文章 0 订阅

Team Formation

Time Limit: 3 Seconds      Memory Limit: 131072 KB

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be A ⊕ B, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. A ⊕ B > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6

Author:

LIN, Xi

Source:

The 12th Zhejiang Provincial Collegiate Programming Contest

思路

位运算题,真心考智商……
假设b比a小,如果a^b>max(a,b),则,b的首1位对应的a的那一位一定是0。
为什么呢,因为如果b的首1位对应的是a的1的话,那么异或出来就是1^1=0,那绝对比a小。
所以先预处理好b[i],保存以i为首1位的数的个数。
然后历遍a[i],找出每一个为0的位,答案加上以这一位为首1位的数的个数即可。

或者反过来想,对每一个a,遍历首1位为i的点(设为b,a>=b),如果对应a的那一位为1,则a^b肯定比a小,反之为0,则肯定比a大。

AC代码

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

unsigned int a[100000+100];
int b[40];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(b,0,sizeof b);
        int n;
        scanf("%d",&n);
        for(int i=0 ; i<n ; ++i)
        {
            scanf("%d",&a[i]);
            for(int j=31 ; j>=0 ; --j)
            {
                if((1<<j)&a[i])
                {
                    b[j]++;
                    break;
                }
            }
        }
        int ans=0;
        for(int i=0 ; i<n ; ++i)
        {
            int j;
            for(j=31 ; j>=0 ; --j)
            {
                if(a[i]&(1<<j))break;
            }
            for( ; j>=0 ; --j)
            {
                if((a[i]&(1<<j))==0)
                {
                    ans+=b[j];
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值