HDU 2135 Rolling table

http://acm.hdu.edu.cn/showproblem.php?pid=2135

 

Rolling table

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1000    Accepted Submission(s): 509


Problem Description
After the 32nd ACM/ICPC regional contest, Wiskey is beginning to prepare for CET-6. He has an English words table and read it every morning.
One day, Wiskey's chum wants to play a joke on him. He rolling the table, and tell Wiskey how many time he rotated. Rotate 90 degrees clockwise or count-clockwise each time.
The table has n*n grids. Your task is tell Wiskey the final status of the table.
 


 

Input
Each line will contain two number.
The first is postive integer n (0 < n <= 10).
The seconed is signed 32-bit integer m.
if m is postive, it represent rotate clockwise m times, else it represent rotate count-clockwise -m times.
Following n lines. Every line contain n characters.
 


 

Output
Output the n*n grids of the final status.
 


 

Sample Input
3 2 123 456 789 3 -1 123 456 789
 


 

Sample Output
987 654 321 369 258 147
 


 

Author
Wiskey
 


 

Source
 


 

Recommend
威士忌
 
题意:输入n m.输入一个char型n*n矩阵,若m为正,顺时针旋转m个90°;若m为负,逆时针旋转-m个90°.输出旋转后的矩阵。
分析:11 12 13 … 1n-1 1n 可以把矩阵写在纸上,然后旋转,得到规律,输出即可   
          21 22 23 … 2n-1 2n
          …                           
            n1 n2 ……  nn-1 nn
代码如下:
#include<stdio.h>
#include<string.h>
int main()
{
  int i,j,n,m;
  char ans[12][12];
  while(scanf("%d%d",&n,&m)==2)
      {
        memset(ans,0,sizeof(ans));
        getchar();
        for(i=1;i<=n;i++)
            {
        for(j=1;j<=n;j++)
                  scanf("%c",&ans[i][j]);
                  if(i!=n) getchar();
            }
              if(m%4==0)
              {
                      for(i=1;i<=n;i++)
                      {
            for(j=1;j<=n;j++)
        printf("%c",ans[i][j]);
        printf("\n");
          }
              }
            if(m%4==1||m%4==-3)
            {
              for(i=1;i<=n;i++)
                      {
            for(j=n;j>0;j--)
        printf("%c",ans[j][i]);
        printf("\n");
          }
          }
          if(m%4==2||m%4==-2)
            {
              for(i=n;i>0;i--)
                      {
            for(j=n;j>0;j--)
        printf("%c",ans[i][j]);
        printf("\n");
          }
          }
          if(m%4==3||m%4==-1)
            {
              for(i=n;i>0;i--)
                      {
            for(j=1;j<=n;j++)
        printf("%c",ans[j][i]);
        printf("\n");
          }
          }
     
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值