HDU 1397 Goldbach's Conjecture

http://acm.hdu.edu.cn/showproblem.php?pid=1397

 

Goldbach's Conjecture

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2722 Accepted Submission(s): 1010


Problem Description
Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.


 

Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.


 

Output
Each output line should contain an integer number. No other characters should appear in the output.


 

Sample Input
6 10 12 0


 

Sample Output
1 2 1


 

Source


 

Recommend
Ignatius.L
题目大意:给一个数,分解成两个数相加,并且这两个数都是素数。
分析:还是素数筛选法,判断一下即可。
代码如下:
#include<stdio.h>
#include<string.h>
#define M 32769
bool prime[M];
void fun()
{
  int i,j;
  memset(prime,1,sizeof(prime));
  for(i=2;i<M;i++)
      {
    for(j=2;j*i<M;j++)
      if(prime[i])
        prime[i*j]=0;
  }
  prime[0]=prime[1]=0;
}
int main()
{
  fun();
  int i,n;
  int count;
  while(scanf("%d",&n),n)
  {
    count=0;
    for(i=2;i<n;i++)
      if(prime[i]&&prime[n-i])
      {
        if(i==n-i) count++;
        count++;
      }
      printf("%d\n",count/2); 
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值