自己感觉这道题还是挺难得,,不容易想。题目让求最多有多少个儿童,,首先逆向转化成求不认识的儿童,,然后再建图转化成最小点集覆盖。。。挺难的。题目:
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 3409 | Accepted: 1599 |
Description
In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.
Input
The input consists of multiple test cases. Each test case starts with a line containing three integers
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.
The last test case is followed by a line containing three zeros.
Output
For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.
Sample Input
2 3 3 1 1 1 2 2 3 2 3 5 1 1 1 2 2 1 2 2 2 3 0 0 0
Sample Output
Case 1: 3 Case 2: 4ac代码:
#include <iostream>
#include <vector>
#include <cstdio>
#include <string.h>
using namespace std;
vector<int> ss[202];
int flag[202],visted[202],map[202][202];
bool dfs(int x){
for(int i=0;i<ss[x].size();++i){
if(!visted[ss[x][i]]){
visted[ss[x][i]]=1;
if(flag[ss[x][i]]==-1||dfs(flag[ss[x][i]])){
flag[ss[x][i]]=x;
return true;
}
}
}
return false;
}
int main(){
int numg,numb,m;
int count=1;
while(scanf("%d%d%d",&numg,&numb,&m)&&numg&&numb&&m){
memset(flag,-1,sizeof(flag));
memset(ss,0,sizeof(ss));
memset(map,0,sizeof(map));
int x,y;
while(m--){
scanf("%d%d",&x,&y);
map[x][y]=1;
}
for(int i=1;i<=numg;++i){
for(int j=1;j<=numb;++j){
if(!map[i][j])
ss[i].push_back(j);
}
}
int sum=0;
printf("Case %d: ",count);
for(int i=1;i<=numg;++i){
memset(visted,0,sizeof(visted));
if(dfs(i))
sum++;
}
printf("%d\n",numg+numb-sum);
count++;
}
return 0;
}