多久了,,,多久了,,,,两天了,,,,终于ac了一道题,,还是一道水题。。。。。。悲剧,,,,杭电上的一道题,,,一直看不懂题意,看不懂,,纠结,,,,就这样一直看了两天,,还是不懂,,,受打击了,,浪费了两天时间,,杭电3336,,,求高手指导。。。题目:
Period
Time Limit: 3000MS | Memory Limit: 30000K | |
Total Submissions: 8387 | Accepted: 3734 |
Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A
K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.
number zero on it.
Output
For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3 aaa 12 aabaabaabaab 0
Sample Output
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4ac代码:
#include <iostream>
#include <cstdio>
#include <string.h>
using namespace std;
const int N=1000010;
int nextt[N];
char str[N];
int len;
void get_nextt(){
nextt[0]=0;
int i,temp;
for(i=1;i<len;++i){
temp=nextt[i-1];
while(temp&&str[temp]!=str[i])
temp=nextt[temp-1];
if(str[temp]==str[i])
nextt[i]=temp+1;
else
nextt[i]=0;
}
}
int main(){
int num=0;
while(scanf("%d",&len)&&len){
scanf("%s",str);
get_nextt();
printf("Test case #%d\n",++num);
for(int i=1;i<len;i++){
if(nextt[i]==0)
continue;
int x=(i+1)-nextt[i];
if(((i+1)%x==0))
printf("%d %d\n",i+1,(i+1)/x);
}
printf("\n");
}
return 0;
}