杭电 1384 差分约束

      第一道差分约束的题,纠结了很久,建图真的好难。这道题因为要求最小值,所以可以求最长路径,当让球最大值的时候,可以求最短路径。题目中给的条件很明显了,还有两个比较隐晦的条件,考虑完整之后图才完整,才可以ac。用si代表前i个元素里有多少个是必须的,则s[i]-s[i-1]<=1,s[i]-s[i-1]>=0,。题目:

Intervals

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1240    Accepted Submission(s): 474


Problem Description
You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.

Write a program that:

> reads the number of intervals, their endpoints and integers c1, ..., cn from the standard input,

> computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i = 1, 2, ..., n,

> writes the answer to the standard output
 

Input
The first line of the input contains an integer n (1 <= n <= 50 000) - the number of intervals. The following n lines describe the intervals. The i+1-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50 000 and 1 <= ci <= bi - ai + 1.

Process to the end of file.

 

Output
The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i = 1, 2, ..., n.
 

Sample Input
  
  
5 3 7 3 8 10 3 6 8 1 1 3 1 10 11 1
 

Sample Output
  
  
6
 

ac代码:

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;
#define M 500010
#define MIN 100000000
int n,mmax=0,mmin=MIN;
int dis[M];
struct edge{
  int leftpoint,rightpoint,value;
}aa[M];
void bellman_ford(){
	for(int i=0;i<=mmax;++i){
	  dis[i]=-MIN;
	}
	dis[mmin]=0;
	for(int i=1;i<=mmax-1;++i){
		bool flag=0;
		for(int j=0;j<n;++j)
		if(dis[aa[j].leftpoint]!=-MIN&&dis[aa[j].leftpoint]+aa[j].value>dis[aa[j].rightpoint]){
			dis[aa[j].rightpoint]=dis[aa[j].leftpoint]+aa[j].value;
			flag=1;
		}
		for(int j=1;j<=mmax;++j){
			if(dis[j-1]!=-MIN&&dis[j]<dis[j-1]){
			  dis[j]=dis[j-1];
			  flag=1;
			}
		}
		for(int j=mmax;j>=1;--j){
			if(dis[j]!=-MIN&&dis[j-1]<dis[j]-1){
			  dis[j-1]=dis[j]-1;
			  flag=1;
			}
		}
		if(!flag)
			break;
	}
}
int main(){
	//freopen("1.txt","r",stdin);
	while(~scanf("%d",&n)){
		for(int i=0;i<n;++i){
			scanf("%d%d%d",&aa[i].leftpoint,&aa[i].rightpoint,&aa[i].value);
			if(mmax<++aa[i].rightpoint)
				mmax=aa[i].rightpoint;
			if(mmin>aa[i].leftpoint)
				mmin=aa[i].leftpoint;
		}
		bellman_ford();
		printf("%d\n",dis[mmax]);
	}
  return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值