The string
APPAPT
contains twoPAT
's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.Now given any string, you are supposed to tell the number of
PAT
's contained in the string.Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 105 characters containing only
P
,A
, orT
.Output Specification:
For each test case, print in one line the number of
PAT
's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.Sample Input:
APPAPT
结尾无空行
Sample Output:
2
结尾无空行
这道题原来在pta乙级的时候做过,不多做讲解。
#include<bits/stdc++.h>
using namespace std;
#define MOD 1000000007
int main()
{
int p=0,a=0,t=0;
char str[100005];
cin>>str;
int m=strlen(str);
for(int i=0;i<m;i++){
if(str[i]=='P') p++;
else if(str[i]=='A') a+=p;
else if(str[i]=='T') t+=a;
t=t%MOD;
}
cout<<t;
}