(POJ - 1328)Radar Installation

(POJ - 1328)Radar Installation

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 90183 Accepted: 20266

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
这里写图片描述
Figure A Sample Input of Radar Installations

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

题目大意:有n个小岛可视为点,海岸视为x轴,海岸上装雷达的可管辖半径是d,问最少需要多少雷达,可是所有小岛都处于管辖范围。

思路:对于每一个小岛,处理出能管辖到他的雷达得范围(即雷达可装的最左边距离和最右边距离)的,按处理出来的左边距离排序,如果有小岛能管辖他的的雷达能装的最左边位置>之前那个,那么就需要再装一个雷达,所有雷达竟可能往右边装,这样才能保证尽量少的雷达管到多有小岛。

#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;

const int maxn=1005;

struct point
{
    double x,y;
}island[maxn];

struct node
{
    double left,right;
}radar[maxn]; 

bool cmp(node a,node b)
{
    return a.left<b.left;
}

int main()
{
    int n,d,kase=1;
    while(~scanf("%d%d",&n,&d)&&n+d)
    {
        bool flag=false;
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&island[i].x,&island[i].y);
            if(island[i].y>(double)d) flag=true; 
        }
        if(flag) 
        {
            printf("Case %d: -1\n",kase++);
            continue;
        }
        for(int i=0;i<n;i++)
        {
            double dx=sqrt(d*d*1.0-island[i].y*island[i].y);
            radar[i].left=island[i].x-dx;
            radar[i].right=island[i].x+dx;
        }
        sort(radar,radar+n,cmp);
        int ans=1;
        double tmp=radar[0].right;
        for(int i=1;i<n;i++)
        {
            if(radar[i].left>tmp)
            {
                ans++;
                tmp=radar[i].right;
            }
            else if(radar[i].right<tmp) tmp=radar[i].right;
        }
        printf("Case %d: %d\n",kase++,ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值