ZOJ 1494 Climbing Worm

Climbing Worm

Time Limit: 2 Seconds       Memory Limit: 65536 KB

An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.


Input

There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.


Output

Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.


Sample Input

10 2 1
20 3 1
0 0 0


Sample Output

17
19

题意:一只1英尺长的虫子爬一口n英尺长的井,每分钟爬u英尺,然后休息1分钟,在休息期间掉下d英尺,爬到井口要用多久。

注意:注意最后是一步d到达的,小心不要把退回来到n算进去

代码:

#include <stdio.h>


int main()
{
    int n,d,u;
    while(scanf("%d%d%d",&n,&d,&u))
    {
        if(n==0&&d==0&&u==0)
            break;
        int i;
        for(i=0;;i++)
        {
            if(i*(d-u)+d>=n)
                break;
        }
        i=2*i+1;
        printf("%d\n",i);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值