ZOJ 1622 Switch

Switch

Time Limit: 2 Seconds       Memory Limit: 65536 KB

There are N lights in a line. Given the states (on/off) of the lights, your task is to determine at least how many lights should be switched (from on to off, or from off to on), in order to make the lights on and off alternatively.


Input

One line for each testcase.

The integer N (1 <= N <= 10000) comes first and is followed by N integers representing the states of the lights ("1" for on and "0" for off).

Process to the end-of-file.


Output

For each testcase output a line consists of only the least times of switches.


Sample Input

3 1 1 1
3 1 0 1


Sample Output

1
0

题意:把序列转换成10101.....或010101...需要改变的最小数目
思路:此题主要思路是,2种方案都实现1次,比较哪个次数少。每次比较好后,n都要变化。
代码:
#include <stdio.h>


int main()
{
    int N;
    int a[10000];
    
    while(scanf("%d",&N)!=EOF)
    {
        int i;
        for(i=0;i<N;i++)
            scanf("%d",&a[i]);
        int n=1,r1=0,r2=0;
        for(i=0;i<N;i++)
        {
            if(a[i]!=n)
                r1++;
            n=1-n;
        }
        n=0;
        for(i=0;i<N;i++)
        {
            if(a[i]!=n)
                r2++;
            n=1-n;
        }
        printf("%d\n",r1<r2?r1:r2);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值