ZOJ 1730 Crazy Tea Party

Crazy Tea Party

Time Limit: 2 Seconds       Memory Limit: 65536 KB

n participants of "crazy tea party" sit around the table. Each minute one pair of neighbors can change their places. Find the minimum time (in minutes) required for all participants to sit in reverse order (so that left neighbors would become right, and right - left).

Input. The first line is the amount of tests. Each next line contains one integer n (1 <= n <= 32767) - the amount of crazy tea participants.

Output. For each number n of participants to crazy tea party print on the standard output, on a separate line, the minimum time required for all participants to sit in reverse order.


Sample Input

3
4
5
6


Sample Output

2
4
6

题意:几个人围成圈,每分钟相邻的2个人可以对调,问最少要用多少时间使每个人原先左右两边的人对调
思路: 先只考虑排成一列的情况。由于只能在邻居之间交换。相当于用冒泡排序排列 n..1 ,需( n-1 n/2 (∵ T(n) = n-1 + T(n)

然后考虑将环转换为非环。即(k k-1 .. 1) (n .. k+1)例如:1 2 3 4 5 6的目标可以是 6 5 4 3 2 1,也可以是 (4 3 2 1 )(6 5)。

相当于进行2个冒泡排序,2个冒泡排序的n相等时,和最小

#include <stdio.h>


int main()
{
    int M;
    scanf("%d",&M);
    
    while(M--){
        int n,k;
        scanf("%d",&n);
        if(n%2==0)
            k=(n/2-1)*(n/2);
        else
            k=((n-1)/2)*((n-1)/2-1)/2+((n+1)/2)*((n+1)/2-1)/2;
        printf("%d\n",k);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值