hdu 3367 Pseudoforest(伪森林)

Problem Description

In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.

Input

The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.
The last test case is followed by a line containing two zeros, which means the end of the input.

Output

Output the sum of the value of the edges of the maximum pesudoforest.

Sample Input

3 3
0 1 1
1 2 1
2 0 1
4 5
0 1 1
1 2 1
2 3 1
3 0 1
0 2 2
0 0

Sample Output

3
5


题意:即求伪森林。给一个图,n个点,m条边,每个连通分量最多有一个环,求最大值。

即求出一个最大的子图(子图的每个连通分量最多有一个环)

注意:类似于求最大生成树,但并不是,不能求最大生成树+最大边,给一个别人博客上写的例子:

6 7
0 1 9
0 2 6
1 2 8
3 4 5
4 5 5
3 5 4
2 4 1
这组数据如果是错误的方法就是34,选择(0,1),(1,2),(0,2),(2,4),(3,4),(4,5)
正确的方法答案是37,选择(0,1),(1,2),(0,2),(3,4),(3,5),(4,5)
正确思路:在最大生成树的基础上判断一下环的问题,按照权值从大到小去边,然后按条件合并

1.两个子树都没有环直接合并

2.两个子树都有环不能合并

3.其中一个有环合并之后要同时标记一下


#include <iostream>
#include <memory.h>
#include <algorithm>
#define NUM 10010

using namespace std;
int n;
int m;
int father[NUM];
int circle[NUM];  //用于标记是否有环,有环为1,无环为0
 struct Edge
{
    int u,v,w;
}e[NUM*10];
void init()
{
    for(int i=0;i<n;i++)
    {
        father[i]=i;
    }
}

int find_father(int x)
{
    if(x==father[x])
        return x;
    else
        return father[x]=find_father(father[x]);
}

int cmp(Edge a,Edge b)
{
    return a.w>b.w;
}

int Krual()
{
    int ans=0;
    memset(circle,0,sizeof(circle));
    for(int i=0;i<m;i++)
    {
        int fa=find_father(e[i].u);
        int fb=find_father(e[i].v);
        if(fa==fb)   //
        {
            if(!circle[fa])
            {
                circle[fa]=1;
                ans+=e[i].w;
            }
            continue;
        }
        if(circle[fa]&&circle[fb])
            continue;
        if(circle[fa]&&!circle[fb])
            father[fb]=fa;
        else
            father[fa]=fb;
        ans+=e[i].w;
    }
    return ans;
}
int main()
{
    while(cin>>n>>m)
    {
        if(n==0&&m==0)
            break;
        init();
        for(int i=0;i<m;i++)
        {
            cin>>e[i].u>>e[i].v>>e[i].w;
        }
        sort(e,e+m,cmp);
        cout<<Krual()<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值