hdu 3371 Connect the Cities (Prim)

Problem Description

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  

Input

The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.

Sample Input

1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6

Sample Output

1


题意:已知若干路径和已经有联系的城市,求最小花费使所有城市相连

注意:必须使用c语言的输入输出,否则会超时

#include <iostream>
#include <memory.h>
#include <stdio.h>
#define INF 0x3f3f3f3f
#define NUM 505

using namespace std;

int n;
bool vis[NUM];
int lowcost[NUM];
int g[NUM][NUM];

int Prim()
{
    int ans=0;
    memset(vis,false,sizeof(vis));
    memset(lowcost,INF,sizeof(lowcost));
    for(int i=1;i<=n;i++)
        lowcost[i]=g[1][i];
    vis[1]=true;
    lowcost[1]=0;
    for(int i=2;i<=n;i++)
    {
        int Min=INF;
        int k=-1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&lowcost[j]<Min)
            {
                Min=lowcost[j];
                k=j;
            }
        }
        if(Min==INF)
            return -1;
        ans+=Min;
        vis[k]=true;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&lowcost[j]>g[k][j]&&g[k][j]!=INF)
            {
                lowcost[j]=g[k][j];
            }
        }

    }
    return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    int m,k,t,a,b;
    int p,q,c;
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&k);
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                g[i][j]=INF;
            }
        }
        while(m--)
        {
            scanf("%d%d%d",&p,&q,&c);
            if(c<g[p][q])
            g[p][q]=g[q][p]=c;
        }
        while(k--)
        {
            scanf("%d%d",&t,&a);
            t=t-1;
            while(t--)
            {
                scanf("%d",&b);
                g[a][b]=g[b][a]=0;
            }
        }
        int ans=Prim();
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值