hdu1506-Largest Rectangle in a Histogram(动态规划)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1506

题目原文:

Largest Rectangle in a Histogram

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24724    Accepted Submission(s): 7814


 

Problem Description

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

 

 

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1 <= n <= 100000. Then follow n integers h1, ..., hn, where 0 <= hi <= 1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

 

 

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

 

 

Sample Input

 

7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
5 2 3 1 2 1
0

 

 

Sample Output

 

8
4000
5

 

题目大意:

        给出一个直方图,宽为1,高为[0, 1e5] ,求能组成的最大矩形的面积。

解题思路:

         主要思路就是找出以当前点位最低点能左右延伸的最长距离,也就是找出最左最右的下标,最后的 ans = max(a[i] * (r[i] - l[i] + 1))。遇到了几个坑,具体在代码注释中。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int N = int(1e5 + 5);

int g_n;
int g_a[N], g_l[N], g_r[N];

void init()
{
    memset(g_a, -1, sizeof(g_a)); // 开始一直初始为0,没看清h是[0, 100000]的,被坑了好久
}

int main()
{
    int i;
    long long ans;
    while (scanf("%d", &g_n), g_n)
    {
        init();
        ans = 0;
        for (i = 1; i <= g_n; i++)
        {
            scanf("%d", &g_a[i]);
            g_l[i] = g_r[i] = i;
        }
        for (i = 1; i <= g_n; i++)
        {
            // 对g_l进行状态转移
            while (g_a[g_l[i] - 1] >= g_a[i])
            {
                g_l[i] = g_l[g_l[i] - 1];
            }
        }
        for (i = g_n; i >= 1; i--)
        {
            // 对g_r进行状态转移
            while (g_a[g_r[i] + 1] >= g_a[i])
            {
                g_r[i] = g_r[g_r[i] + 1];
            }
        }

        for (i = 1; i <= g_n; i++)
        {
            ans = max(ans, 1LL * g_a[i] * (g_r[i] - g_l[i] + 1)); // 1LL * 转化long long型,不然int计算已经越界再转就无效了
        }
        printf("%lld\n", ans);
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值