检查密码

这篇博客介绍了如何编写一个密码合法性检查的功能,要求密码至少包含6个字符,仅能由英文字母、数字和小数点组成,并且必须同时包含字母和数字。给出了输入输出样例及代码实现,代码使用C语言编写,通过遍历字符串检查字符类型来判断密码是否符合规定。
摘要由CSDN通过智能技术生成

一、题目描述

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

二、输入格式

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

注意: 题目保证不存在只有小数点的输入。

三、输出格式

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

  • 如果密码合法,输出Your password is wan mei.
  • 如果密码太短,不论合法与否,都输出Your password is tai duan le.
  • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.
  • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.
  • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.

四、输入样例

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

五、代码演示 

#include<stdio.h>
#include<string.h>
int main()
{
    int n;
    scanf("%d", &n);//输出n
    getchar();
    char a[81];

    int len;
    while (n--)
    {
        int cha = 0, num = 0, point = 0, other = 0;
        gets(a);
        len = strlen(a);
        if (len < 6) {
            printf("Your password is tai duan le.\n");
            continue;
        }
        else for (int i = 0; i < len; i++)
        {
            if (a[i] >= '0' && a[i] <= '9')num++;
            else if (a[i] >= 'a' && a[i] <= 'z' || a[i] >= 'A' && a[i] <= 'Z')cha++;
            else if (a[i] == '.')point++;
            else other++;
        }
        if (other != 0)printf("Your password is tai luan le.\n");
        else if (cha != 0 && num == 0)printf("Your password needs shu zi.\n");
        else if (cha == 0 && num != 0)printf("Your password needs zi mu.\n");
        else printf("Your password is wan mei.\n");
    }
    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

名之以父

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值