hdu 多校联赛 RXD and math

RXD and math

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 1832    Accepted Submission(s): 745


Problem Description
RXD is a good mathematician.
One day he wants to calculate:
i=1nkμ2(i)×nki

output the answer module  109+7 .
1n,k1018
μ(n)=1(n=1)

μ(n)=(1)k(n=p1p2pk)

μ(n)=0(otherwise)

p1,p2,p3pk  are different prime numbers
 

Input
There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers  n,k .
 

Output
For each test case, output "Case #x: y", which means the test case number and the answer.
 

Sample Input
  
  
10 10
 

Sample Output
  
  
Case #1: 999999937

题意:如同题目所说,输入n和k求题目中的公式的结果。

这道题上去看的时候一脸懵逼 就拿着公式做文章 看看能不能拆解公式 划减一下公式 降低公式的复杂度 后来听到其他队友对公式进行打表找规律 打了100以内的数进行打表发现结果就是快速幂n^k%(10^9+7)代码如下 因为代码比较简单 就不给大家解释了

ac代码:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
const int mod=1e9+7;

long long quick_multi(long long a,long long b)
{
    long long ans=0;
    while(b)
    {
        if(b&1)
        {
            ans=(ans+a)%mod;
            b--;
        }
        b>>=1;
        a=(a<<1)%mod;
    }
    return ans;
}
long long quick_mod(long long a,long long b)
{
    long long ans=1;
    while(b)
    {
        if(b&1)
        {
            ans=quick_multi(ans,a);
            b--;
        }
        b>>=1;
        a=quick_multi(a,a);
    }
    return ans;
}
int main()
{
    long long n,k;
    int ca=0;
    while(scanf("%I64d%I64d",&n,&k)!=EOF)
    {
        n%=mod;
        ca++;
    printf("Case #%d: %I64d\n",ca,quick_mod(n,k));
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值