hdu 多校联赛 Classes

Classes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
The school set up three elective courses, assuming that these courses are A, B, C. N classes of students enrolled in these courses.
Now the school wants to count the number of students who enrolled in at least one course in each class and records the maximum number of students.
Each class uploaded 7 data, the number of students enrolled in course A in the class, the number of students enrolled in course B, the number of students enrolled in course C, the number of students enrolled in course AB, the number of students enrolled in course BC, the number of students enrolled in course AC, the number of students enrolled in course ABC. The school can calculate the number of students in this class based on these 7 data.
However, due to statistical errors, some data are wrong and these data should be ignored.
Smart you must know how to write a program to find the maximum number of students.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integer N, indicates the number of class.
Then N lines follow, each line contains 7 data: a, b, c, d, e, f, g, indicates the number of students enrolled in A, B, C, AB, BC, AC, ABC in this class. 
It's guaranteed that at least one data is right in each test case.

Limits
T100
1N100
0a,b,c,d,e,f,g100
 

Output
For each test case output one line contains one integer denotes the max number of students who enrolled in at least one course among N classes.
 

Sample Input
  
  
2 2 4 5 4 4 3 2 2 5 3 1 2 0 0 0 2 0 4 10 2 3 4 9 6 12 6 3 5 3 2
 

Sample Output
  
  
7 15
Hint
In the second test case, the data uploaded by Class 1 is wrong. Because we can't find a solution which satisfies the limitation. As for Class 2, we can calculate the number of students who only enrolled in course A is 2, the number of students who only enrolled in course B is 6, and nobody enrolled in course C, the number of students who only enrolled in courses A and B is 1, the number of students who only enrolled in courses B and C is 3, the number of students who only enrolled in courses A and C is 1, the number of students who enrolled in all courses is 2, so the total number in Class 2 is 2 + 6 + 0 + 1 + 3 + 1 + 2 = 15.
 
非常简单的一道题 但是第一次交的时候还是掉到坑里去了 列出判断数据是错误的条件就行了 可以画三个圆代表三门课 然后看看他们之间的关系即可

ac代码:

#include<bits/stdc++.h>
using namespace std;
#define inf 0x3f3f3f
int num[7+5];
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int ans = -1;
        for(int i = 0; i <n; ++i)
        {
            int a = inf,b = inf,c = inf,d = inf;
            memset(num,0,sizeof(num));
            for(int i = 0; i<7; ++i)
            {
                scanf("%d",&num[i]);
            }
            d = num[0]+num[1]+num[2]-num[3]-num[4]-num[5]+num[6];
            if(num[3]<=num[0]&&num[5]<=num[0]&&num[6]<=min(num[3],num[5]))//对后边几个交集判断大小关系
            {
               a = num[3]+num[5]-num[6];
            }
            if(num[3]<=num[1]&&num[4]<=num[1]&&num[6]<=min(num[3],num[4]))
            {
                b = num[3]+num[4]-num[6];
            }
            if(num[4]<=num[2]&&num[5]<=num[2]&&num[6]<=min(num[4],num[5]))
            {
               c = num[4]+num[5]-num[6];
            }
            if(a<=num[0]&&b<=num[1]&&c<=num[2]&&d>ans)//更新ans
            {
                ans = d;
            }
        }
        printf("%d\n",ans);

    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值