Problem F: 我是好人
Description
众所周知,我是好人!
所以不会出太难的题,题意很简单 给你两个数n和m,问你有多少对正整数对最大公约数是n,最小公倍数是m
最后友情提供解题代码(我真是太好人了)
void solve()
{
long long n, m;
scanf("%lld%lld", &n, &m);
int ans = 0;
for (long long i = 1; i <= m; i++)
{
for (long long j = i; j <= m; j++)
{
if (gcd(i, j) == n && lcm(i, j) == m) ans++;
}
}
printf("%d\n", ans);
}
祝大家AC愉快!最好AK,送某扬兑现诺言^_^
Input
输入第1行是一个整数T,表示共T组数据。 接下来是T组数据,每组数据占1行,每一行有2个整数n,m(1 <= n, m <= 10000000000),两个数由一个空格隔开。
Output
结果输出T行,对应T组数据。(T<=100)
每行输出这样的正整数对有多少对(看我多好人,不用你们输出所有整数对)
Sample Input
3
1 1
7 10086
4 16
Sample Output
1
0
1
如果存在这样的数对,那么m%n==0,比如 a=9 和 b=15 9=3*3 15=3*15 n=3 m=3*3*5 即m=n*(a与b互质的数的乘积)。所以直接枚举 1~m/n 范围内所有互质的数对就可以啦
#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#define ll long long
using namespace std;
ll t,n,m;
ll gcd(ll a,ll b)
{
if(b==0) return a;
return gcd(b,a%b);
}
ll fun(ll x)
{
ll num=0;
for(ll i=1;i*i<=x;i++)
if(x%i==0)
{
ll j=x/i;
if(gcd(i,j)==1) num++;
}
return num;
}
int main()
{
while(~scanf("%d",&t))
{
while(t--)
{
scanf("%lld %lld",&n,&m);
if(m%n)
{
printf("0\n");
continue;
}
ll a=m/n;
printf("%lld\n",fun(a));
}
}
return 0;
}