POJ1094Sorting It All Out 拓扑排序

Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 29359 Accepted: 10170

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

#include <stdio.h>
#include <string>
#include <cstring>
#include <iostream>
#include <cmath>
#include <queue>
#include <stack>
#define N 1009

using namespace std;


char s[N];
int mp[27][27];
int q[N];
int deg[N];

int topo(int n)
{
    int c=0,temp[27],m,loc,flag=1;

    for(int i=1;i<=n;i++)
    temp[i]=deg[i];

    for(int i=1;i<=n;i++)
    {
        m=0;
        for(int j=1;j<=n;j++)
        if(temp[j]==0)
        {
            m++;
            loc=j;
        }

        if(m==0)
        return 0;//有环
        if(m>1)
        flag=-1;//无环

        q[c++]=loc;
        temp[loc]=-1;

        for(int j=1;j<=n;j++)
        if(mp[loc][j]==1)
        temp[j]--;

    }

   return flag;
}


int main()
{
    int n,m;
    while(~scanf("%d %d",&m,&n))
    {
        if(n==0 && m==0) break;

        memset(mp,0,sizeof mp);
        memset(deg,0,sizeof deg);

        int flag=0;

        for(int i=1;i<=n;i++)
        {
            scanf("%s",s);

            if(flag) continue;
            int a=s[0]-'A'+1;
            int b=s[2]-'A'+1;
            mp[a][b]=1;
            deg[b]++;

            int ans=topo(m);

            if(ans==0)
            {
                cout<<"Inconsistency found after "<<i<<" relations."<<endl;
                flag=1;
            }

            if(ans==1)
            {
                cout<<"Sorted sequence determined after "<<i<<" relations: ";

                for(int j=0;j<m;j++)
                printf("%c",q[j]-1+'A');
                cout<<".\n";
                flag=1;

            }
        }

        if(flag==0)
        cout<<"Sorted sequence cannot be determined."<<endl;

    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值