Dining poj 3281 拆点+

Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8318 Accepted: 3844

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers:  NF, and  D 
Lines 2.. N+1: Each line  i starts with a two integers  Fi and  Di, the number of dishes that cow  i likes and the number of drinks that cow  i likes. The next  Fi integers denote the dishes that cow  i will eat, and the  Di integers following that denote the drinks that cow  i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint

One way to satisfy three cows is: 
Cow 1: no meal 
Cow 2: Food #2, Drink #2 
Cow 3: Food #1, Drink #1 
Cow 4: Food #3, Drink #3 
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

Source



做这个题目依旧感到很忧桑,唉,建图还是看人家的,什么时候自己也能建出图来啊!!!!这个题目是说有n个牛,f个食物,d个饮料,每个牛只能喝一个饮料吃一个食物,而且给出N行,给出喜欢的食物和饮料的种类数,然后是编号,建图的时候要创建一个源点和食物相连,食物和牛相连,牛和牛相连,牛再跟饮料连,饮料和汇点连,流都为 1,就完了。牛和牛的拆点是为了保证牛只能喝一个饮料吃一个食物,要保证只吃一种食物和一种饮料,而不是0,2的搭配,只能把牛放在中间,并且拆点,唉,自己实在是想不到的啊!!!可怜


//SAPËã·¨
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define inf 9999999999
#define M 1007
#define MIN(a,b) a>b?b:a;
using namespace std;
struct E
{
    int v,w,next;
}edg[500000];
int dis[2000],gap[2000],head[2000],nodes;
int sourse,sink,nn;
void addedge(int u,int v,int w)
{
    edg[nodes].v=v;
    edg[nodes].w=w;
    edg[nodes].next=head[u];
    head[u]=nodes++;
    edg[nodes].v=u;
    edg[nodes].w=0;
    edg[nodes].next=head[v];
    head[v]=nodes++;
}
int dfs(int src,int aug)
{
    if(src==sink)return aug;
    int left=aug,mindis=nn;
    for(int j=head[src];j!=-1;j=edg[j].next)
    {
    	int v=edg[j].v;
    	if(edg[j].w)
        {
           if(dis[v]+1==dis[src])
           {
               int minn=MIN(left,edg[j].w);
               minn=dfs(v,minn);
               edg[j].w-=minn;
               edg[j^1].w+=minn;
               left-=minn;
               if(dis[sourse]>=nn)return aug-left;
               if(left==0)break;
           }
           if(dis[v]<mindis)
           mindis=dis[v];
        }
    }

        if(left==aug)
        {
            if(!(--gap[dis[src]]))dis[sourse]=nn;
            dis[src]=mindis+1;
            gap[dis[src]]++;
        }
        return aug-left;
}
int sap(int s,int e)
{
    int ans=0;
	nn=e+1;
    memset(dis,0,sizeof(dis));
    memset(gap,0,sizeof(gap));
    gap[0]=nn;
    sourse=s;
    sink=e;
    while(dis[sourse]<nn)
    ans+=dfs(sourse,inf);
    return ans;
}
int main()
{
        int n,f,d;
        while(scanf("%d%d%d",&n,&f,&d)!=EOF)
        {

         memset(head,-1,sizeof(head));
         nodes=0;
         int s=0;
         int i,j;
         int t=f+2*n+1+d;
         int food,drink;
         int a,b;
         for(i=1;i<=n;i++)
         {
             scanf("%d%d",&food,&drink);
             for(j=1;j<=food;j++)
             {
                 scanf("%d",&a);
                 addedge(a,i+f,1);//食物和牛
             }
             for(j=1;j<=drink;j++)
             {
                 scanf("%d",&b);
                 addedge(i+f+n,f+2*n+b,1);//牛和饮料
             }
         }
         for(i=1;i<=f;i++)
         {
             addedge(s,i,1);
         }
         for(i=1;i<=d;i++)
         {
             addedge(f+2*n+i,t,1);
         }
         for(i=1;i<=n;i++)
         {
             addedge(i+f,i+f+n,1);
         }

         int anss=sap(s,t);
         printf("%d\n",anss);
        }
    return 0;
}











  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值