【POJ 】POJ 3281. Dining - 最大流

POJ 3281. Dining

POJ的题目有很多都是跟牛Cow有关的。2381也不例外。先看一下题目的要求。

Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 20170 Accepted: 8966

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers:  NF, and  D 
Lines 2.. N+1: Each line  i starts with a two integers  Fi and  Di, the number of dishes that cow  i likes and the number of drinks that cow  i likes. The next  Fi integers denote the dishes that cow  i will eat, and the  Di integers following that denote the drinks that cow  i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

题解

  一头牛匹配一样食物就是匹配,直接用匈牙利算法(或最大流),但是本题要求的是一头牛匹配一样食物和一样饮料, 所以建立有向图需要想一下, 最后建立得到的图是一个源点->食物->牛->牛->饮料->终点, 中间两层牛是因为需要限制一头牛只能分配一组饮料和食物, 而不是多组。

 

#include<iostream>
#include<vector>
#include<stack>
#include<stdio.h>
#include<string.h>
using namespace std;
#define showM(M, a, b) { \
    for (int i = 0; i < a; i++) { \
        for (int j = 0; j < b; j++) { \
            printf("%d ", M[i][j]); \
        }\
        printf("\n");\
    }\
    printf("\n");\
}
int F, N, D;
const int MAX_N = 110;
const int MAX_V = 500;
const int MAX_F = 110;
const int INF = 1e9;
bool used[MAX_V];
struct Edge { int to, cap, rev;
    Edge(int a, int b, int c): to(a), cap(b), rev(c) {}
};
vector<Edge> G[MAX_V];
int src, dst;
stack<Edge> st;
void debug(stack<Edge>& st) {
    while (!st.empty()) {
        Edge& e = st.top();
        printf("%d,%d->", e.to, e.cap);
        st.pop();
    }
    printf("end\n");
}
int dfs(int v, int t, int f) {
    if (v == t) return f;
    used[v] = true;
    for (int i = 0; i < G[v].size(); i++) {
        Edge& e = G[v][i];
        if (G[v][i].cap > 0 && !used[e.to]) {
            int d = dfs(e.to, t, min(f, e.cap));
            if (d > 0) {
                // since there's an augmented road, save the current edge
                // st.push(e);
                // if (v == src) debug(st);
                e.cap -= d;
                G[e.to][e.rev].cap += d;
                return d;
            }
        }
    }
    return 0;
}
void addEdge(int from, int to, int cap) {
    G[from].push_back(Edge(to, cap, G[to].size()));
    G[to].push_back(Edge(from, 0, G[from].size() - 1));
}
int max_flow(int s, int t) {
    int flow = 0;
    while (1) {
        memset(used, 0, sizeof(used));
        int f = dfs(s, t, INF);
        if (f == 0) return flow;
        // printf("add %d\n", f);
        flow += f;
    }
}
int main() {
    // 0~N-1, N~2N-1, 2N~2N+F, 2N+F+D
    while (cin >> N >> F >> D) {
        int k, m, f1, f2;
        src = 2 * N + F + D;
        dst = src + 1;
        for (int i = 0; i < dst; i++) {
            G[i].clear();
        }
        for (int k = 1; k <= N; k++) {
            cin >> f1 >> f2;
            for (int i = 0; i < f1; i++) {
                cin >> m;
                // assert(m <= F);
                addEdge(m + 2 * N - 1, k - 1, 1);
            }
            for (int i = 0; i < f2; i++) {
                cin >> m;
                // assert(m <= D);
                addEdge(k + N - 1, 2 * N + F + m - 1, 1);
            }
        }
        for (int i = 0; i < N; i++) {
            addEdge(i, i + N, 1);
        }
        for (int i = 0; i < F; i++) {
            addEdge(src, i + 2 * N, 1);
        }
        for (int i = 0; i < D; i++) {
            addEdge(2 * N + F + i, dst, 1);
        }
        // for (int i = 0; i < dst; i++) {
        //     printf("%d: ", i);
        //     for (int j = 0; j < G[i].size(); j++) {
        //         printf("%d %d  ", G[i][j].to, G[i][j].cap);
        //     }
        //     printf("\n");
        // }
        // showM(likeF, N, F);
        // showM(likeD, N, D);
        printf("%d\n", max_flow(src, dst));
    }
    return 0;
}

结果: 

 

转载于:https://www.cnblogs.com/wangzming/p/8252320.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值