HDU 1789(贪心)

问题描述:

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores. 

Output

For each test case, you should output the smallest total reduced score, one line per test case. 

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5
题目题意:题目给我们n个作业期限时间和它不完成的代价,每一天可以完成一个作业,作业不完成就会得到它的代价,问最小的代价是多少?

题目分析:很明显,代价越高的作业应该优先完成,代价相等的应该先完成期限短的,我们按照要求排序后,遍历每个作业,时间上从它的期限往前遍历,找到了一个没用过的时间就可以做这次作业了,反之加上代价。

代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn=1e3+100;
struct note
{
    int t,v;
}point[maxn];
bool vis[maxn];
bool cmp(struct note a,struct note b)
{
    if (a.v==b.v) return a.t<b.t;
    else return a.v>b.v;
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while (t--) {
        scanf("%d",&n);
        for (int i=0;i<n;i++) {
            scanf("%d",&point[i].t);
        }
        for (int i=0;i<n;i++) {
            scanf("%d",&point[i].v);
        }
        sort(point,point+n,cmp);
        memset (vis,false,sizeof (vis));
        int ans=0;
        for (int i=0;i<n;i++) {
            bool flag=false;
            for (int j=point[i].t;j>=1;j--) {
                if (!vis[j]) {
                    vis[j]=true;
                    flag=true;
                    break;
                }
            }
            if (!flag) ans+=point[i].v;
        }
        printf("%d\n",ans);
    }
    return 0;
}













  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值