uva 673 Parentheses Balance(栈)

Parentheses Balance

You are given a string consisting of parentheses () and []. A string of this type is said to be correct:

(a)
if it is the empty string
(b)
if A and B are correct, AB is correct,
(c)
if A is correct,  (A ) and  [A ] is correct.

Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.

Input 

The file contains a positive integer  n  and a sequence of  n  strings of parentheses  ()  and  [] , one string a line.

Output 

A sequence of  Yes  or  No  on the output file.

Sample Input 

3
([])
(([()])))
([()[]()])()

Sample Output 

Yes
No
Yes

题目大意:确定括号是否匹配。

解题思路:左括号入栈,右括号匹配出栈,注意空语句要输出Yes。

#include <cstdio>
#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <ctime>
#include <cmath>
#include <string>
#include <cstring>
#include <stack>
#include <queue>
#include <list>
#include <vector>
#include <map>
#include <set>
#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535897932384626
#define eps 1e-10

#define maxm 400007
#define maxn 1000009

using namespace std;

int main()
{
    char s[150];
    bool flag;

    int n;
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        flag=true;
        memset(s,0,sizeof s);
        gets(s);
        int len=strlen(s);

        stack<char>q;
        for(int i=0;i<len;i++)
        {
            if(s[i]=='('||s[i]=='[')
            {
                q.push(s[i]);
            }
            else if(s[i]==')')
            {
                if(q.empty()||q.top()!='(')
                {
                    flag=false;
                    break;
                }
                else
                {
                    q.pop();
                }
            }
            else if(s[i]==']')
            {
                if(q.empty()||q.top()!='[')
                {
                    flag=false;
                    break;
                }
                else
                {
                    q.pop();
                }
            }
        }
        if(flag&&q.empty())
            puts("Yes");
        else
            puts("No");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值