HDUOJ3336Count the string (KMP)(next[ ]理解应用)(DP)

HDUOJ3336

Problem Description

It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input

The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output

For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input

 
 
14abab
 

Sample Output

 
 
6
题意:给定一个字符串,找出他的所有前缀,输出这些前缀在这个字符串中出现的次数总和

思路:ne[i]中存的值就代表在s[i]前面有ne[i]个字符与前缀相同,then用动态规划,开一个数组用ans[i]记录当再加一个字符变成i个时多出多少个符合条件的字符串,而ans[i]恰好是ans[ne[i]]+1,即当从i-1个字符变成i个时新出现的符合条件的字符串和与其相同的前缀中符合条件的字符串个数相同然后再加上他自己(努力在说明白了.....)

然后举个栗子比如

i:0 1 2 3 4 5 6 7 

s:a b a b a b a b

到标号2的a时,比前面的ab多加了一个a完了以后多出来的前缀就是a(ne[]中的)和aba

代码

#include<cstdio>
#include<iostream>
#include<cstring>
#include<set>
using namespace std;
#define N 200010
int ne[N];
int ans[N];
char a[N];
int t;
int n;
void getne(char *s)
{
    int i=0,j=-1;
    ne[0]=-1;
    while(i<n)
    {
        if(j==-1||s[i]==s[j])
        ne[++i]=++j;
        else j=ne[j];
    }
}
int main()
{

    cin>>t;
    while(t--)
    {
        int sum=0;
        memset(ne,0,sizeof(ne));
        memset(ans,0,sizeof(ans));
        cin>>n;
        scanf("%s",a);
        getne(a);
        for(int i=1;i<=n;i++)
        {
            ans[i]=ans[ne[i]]+1;
            sum=(sum+ans[i])%10007;
        }
        cout<<sum<<endl;

    }
    return 0;
}

emmmmmmm思考了很久的一个题......

状态不好,感谢小谢同学给的动力

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值