poj 3349 Snowflake Snow Snowflakes

Snowflake Snow Snowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 44089 Accepted: 11538
Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5
Sample Output

Twin snowflakes found.
Source

CCC 2007

附上题目链接:http://poj.org/problem?id=3349

思路:(注释里写的解决了我当时的疑惑)
两个雪花是否相等,我们可以枚举,顺逆比较。
O(n2)比较?

所以我们要用hash的方法做这道题。
如果两片雪花相同,那么它们六个角的和必然相同。
所以我们把六个角和相同的hash到一个容器里。
把同一个容器里的雪花拿出来比较。
这样大大缩减了时间。

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
const int N=100005;
const int prime=100000;
int n;
int snow[N][7];
vector<int >V[prime];
int cmp(int pos1, int pos2)
{
    int i, j;
    for(i=0;i<6;i++)
    {
        if(snow[pos1][0]==snow[pos2][i])
        {
            for(j=1;j<6;j++)
                if(snow[pos1][j]!=snow[pos2][(i+j)%6])   //顺时针;
                    break;
            if(j==6) return true;
            for(j=1;j<6;j++)
                if(snow[pos1][6-j]!=snow[pos2][(i+j)%6])    //逆时针;
                    break;
            if(j==6) return true;
        }
    }
    return false;
}
int check()
{
    for(int i=0;i<prime;i++)   //依次在每个边数相等的vector[i]里找是否存在两个相同的雪花;
        for(int j=0;j<V[i].size();j++)
            for(int k=j+1;k<V[i].size();k++)
                if(cmp(V[i][j], V[i][k]))
                    return 1;
    return 0;
}
int main()
{
    while(~scanf("%d", &n))
    {
        for(int i=0;i<n;i++)
        {
            int sum=0;
            for(int j=0;j<6;j++)
            {
                scanf("%d", &snow[i][j]);
                sum+=snow[i][j];
            }
            V[sum%prime].push_back(i);    //把那些6个边相加之和相等的雪花存到一个vector[i]里;
        }
        if(check())
            printf("Twin snowflakes found.\n");
        else printf("No two snowflakes are alike.\n");
    }
}
//这个题的key是雪花边数相加之和;
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值