POJ——1979Red and Black

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 26448 Accepted: 14371

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
 
简单深搜
代码如下
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<ctype.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<set>
#include<vector>
#include<queue>
#include<map>
#include<numeric>
#include<stack>
#include<list>
const int INF=1<<30;
const int inf=-(1<<30);
const int MAX=100010;


using namespace std;


int n,m,t;
char a[30][30];
int s1[4]= {-1,1,0,0};
int s2[4]= {0,0,-1,1};
int visit[30][30];


void dfs(int x,int y)
{
    t++;
    visit[x][y]=1;
    for(int i=0; i<4; i++)
    {
        int t1=s1[i]+x;
        int t2=s2[i]+y;
        if(t1>=0&&t1<m&&t2>=0&&t2<n&&a[t1][t2]=='.'&&!visit[t1][t2])
        {
            visit[t1][t2]=1;
            dfs(t1,t2);
        }
    }
    return ;
}


int main()
{
    int q,p;
    while(cin>>n>>m,n&&m)
    {
        memset(visit,0,sizeof(visit));
        for(int i=0; i<m; i++)
        {
            for(int j=0; j<n; j++)
            {
                cin>>a[i][j];
                if(a[i][j]=='@')
                {
                    p=i;
                    q=j;
                }
            }
        }
        t=0;
        dfs(p,q);
        printf("%d\n",t);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值