Red and Black
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above. Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. '.' - a black tile '#' - a red tile '@' - a man on a black tile(appears exactly once in a data set) The end of the input is indicated by a line consisting of two zeros. Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input 6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0 Sample Output 45 59 6 13 Source |
题意:一个w*h的矩阵,从‘@’出发,如果是 ' . ' 则可以通行,如果是 ' # ' 则不可通行。计算一条路线的最大距离,加上本身所在的位置。
解:使用dfs进行搜索,并使用v[i][j]来标记是否走过此处,如果走过则标记为1。进行上下左右四个方向的搜索。
#include<stdio.h>
#include<string.h>
char a[25][25];
int v[25][25];
int n,t,count;
void dfs(int x,int y)
{
if(x<0 || y<0 || x>=n || y>=t)
return ;
if(a[x][y]=='#')
return;
if(v[x][y])
return;
else if(a[x][y]=='.'){
v[x][y]=1;
count++;
}
dfs(x+1,y);
dfs(x-1,y);
dfs(x,y+1);
dfs(x,y-1);
}
int main()
{
int ii,jj;
while(scanf("%d%d",&t,&n) && n && t){
getchar();
for(int i=0;i<n;i++){
for(int j=0;j<t;j++){
scanf("%c",&a[i][j]);
if(a[i][j]=='@'){
ii=i;
jj=j;
}
}
getchar();
}
memset(v,0,sizeof(v));
count=0;
dfs(ii,jj);
printf("%d\n",count+1);
}
return 0;
}