UVA116多段图的最短路

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu


Description


Background

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) -- finding whether all the cities in a salesperson's route can be visited exactly once with a specified limit on travel time -- is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check.

This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

The Problem

Given an tex2html_wrap_inline352 matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix ``wraps'' so that it represents a horizontal cylinder. Legal steps are illustrated below.

picture25

The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.

For example, two slightly different tex2html_wrap_inline366 matrices are shown below (the only difference is the numbers in the bottom row).

picture37

The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

The Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed bytex2html_wrap_inline376 integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path's weight will exceed integer values representable using 30 bits.

The Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

Sample Input

5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10

Sample Output

1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1
19
 
  
/*
Sample Input
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10
Sample Output
1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1
19
题意:输入一个整形矩阵,从第一列任意位置出发每次往右,右上,右下走一格,最终到达最后一列
要求经过的整形之和最小,矩阵是环形,即第一行的上一行是最后一行,最后一行的下一行是第一行。
输出路径上面每一列的行号,如果存在多解,输出字典序最小的。
*/
// UVa116 Unidirectional TSP
// 环形矩阵
// 算法:多段图的动态规划。因为要字典序最小,所以倒着来,设d[i][j]为从(i,j)到最后一列的最小开销,则d[i][j]=a[i][j]+max(d[i+1][j+1],d[i-1][j+1])
#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn = 100 + 5;
const int INF = 1000000000;
int m, n, a[maxn][maxn], d[maxn][maxn], next[maxn][maxn];

int main()
{
    ///注意输入语句
    while(scanf("%d%d", &m, &n) == 2 && m)  ///m表示行 n表示列
    {
        for(int i = 0; i < m; i++)
            for(int j = 0; j < n; j++)
                scanf("%d", &a[i][j]);

        int ans = INF, first = 0;
        ///从最后一列往前递推
        for(int j = n-1; j >= 0; j--)///对应列
        {
            for(int i = 0; i < m; i++)///对应行
            {
                if(j == n-1) d[i][j] = a[i][j];///边界
                else
                {
                    int rows[3] = {i, i-1, i+1};///对应下一步可以走的三个行
                    ///注意要判断第i行是否属于第0行或者第m-1行
                    if(i == 0) rows[1] = m-1;   ///如果等于0的时候,则它的下一行是最后一行,即m-1
                    if(i == m-1) rows[2] = 0;   ///此时它的下一行是第一行

                    sort(rows, rows+3); ///从小到大,先取最小行,要满足字典序

                    d[i][j] = INF;
                    for(int k = 0; k < 3; k++)
                    {
                        int v = d[rows[k]][j+1] + a[i][j];///用上一列所求的最小值去更新现在的v值
                        if(v < d[i][j])///寻找值最小的一个
                        {
                            d[i][j] = v;
                            next[i][j] = rows[k];///存取的是行
                        }
                    }
                }
                if(j == 0 && d[i][j] < ans)///到达第0列,而且现在所求的值比原来的值还要小,对原来的值进行更新
                {
                    ans = d[i][j];
                    first = i;///记录行
                }
            }
        }
        printf("%d", first+1);
        for(int i = next[first][0], j = 1; j < n; i = next[i][j], j ++)///j对应列
            printf(" %d", i+1);
        printf("\n%d\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值