HDU 3076 ssworld VS DDD 概率DP入门

题目描述:

Problem Description
One day, sssworld and DDD play games together, but there are some special rules in this games.
They both have their own HP. Each round they dice respectively and get the points P1 and P2 (1 <= P1, P2 <= 6). Small number who, whose HP to reduce 1, the same points will remain unchanged. If one of them becomes 0 HP, he loses.
As a result of technical differences between the two, each person has different probability of throwing 1, 2, 3, 4, 5, 6. So we couldn’t predict who the final winner.

Input
There are multiple test cases.
For each case, the first line are two integer HP1, HP2 (1 <= HP1, HP2 <= 2000), said the first player sssworld’s HP and the second player DDD’s HP.
The next two lines each have six floating-point numbers per line. The jth number on the ith line means the the probability of the ith player gets point j. The input data ensures that the game always has an end.

Output
One float with six digits after point, indicate the probability sssworld won the game.

Sample Input

5 5
1.000 0.000 0.000 0.000 0.000 0.000
0.000 0.000 0.000 0.000 0.000 1.000
5 5
0.000 0.000 0.000 0.000 0.000 1.000
1.000 0.000 0.000 0.000 0.000 0.000

Sample Output

0.000000
1.000000

Source
2009 Multi-University Training Contest 17 - Host by NUDT

题目分析:

A与B玩掷骰子游戏。每个人都有一定的血量,再给出每个人掷1~6的概率,输了一次扣一滴血,到0血就输了。求A能够赢得概率。
这题是概率DP的入门,记录下A和B赢得概率并对他们的血量进行DP。
这题我居然MLE了。原来是对double的二维数组进行memset的问题。

代码如下:

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;
const int MAXN =2005;

double aa[7],bb[7];
int a,b;
double pa,pb;//pa表示a一次赢得几率 pb同理
double tie;
double dp[MAXN][MAXN];//dp[i][j]表示第一个人有i血赢了有j血的第二个人的概率

int main()
{
    while(~scanf("%d%d",&a,&b))
    {
        for(int j=1; j<=6; j++)
        {
            scanf("%lf",&aa[j]);
        }
        for(int j=1; j<=6; j++)
        {
            scanf("%lf",&bb[j]);
        }
        pa=pb=0.0;
        //memset(dp,0,sizeof(dp));这个东西这么占内存空间吗
        for(int i=2; i<=6; i++)
        {
            for(int j=1; j<i; j++)
            {
                pa+=aa[i]*bb[j];//a取i赢的几率
                pb+=bb[i]*aa[j];//b取i赢的几率
            }
        }
        tie=1-pa-pb;
        pa=pa/(1.0-tie);
        pb=pb/(1.0-tie);
        //printf("%lf %lf\n",pa,pb);
        dp[0][0]=1;
        for(int i=0; i<a; i++)
        {
            for(int j=0; j<=b; j++)
            {
                if (i || j)
                {
                    dp[i][j]=0.0;
                    if (i) dp[i][j]+=dp[i-1][j]*pa;//a赢一次
                    if (j) dp[i][j]+=dp[i][j-1]*pb;//b赢一次
                }
            }
        }
        double ans=0;
        for(int i=0; i<b; i++) ans+=dp[a-1][i]*pa;
        printf("%.6lf\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值