HDU5762 Teacher Bo 带处理的暴力

题目描述:

Problem Description
Teacher BoBo is a geography teacher in the school.One day in his class,he marked N points in the map,the i-th point is at (Xi,Yi).He wonders,whether there is a tetrad (A,B,C,D)(A < B, C < D,A≠CorB≠D) such that the manhattan distance between A and B is equal to the manhattan distance between C and D.

If there exists such tetrad,print “YES”,else print “NO”.

Input
First line, an integer T. There are T test cases.(T≤50)

In each test case,the first line contains two intergers, N, M, means the number of points and the range of the coordinates.(N,M≤10^5).

Next N lines, the i-th line shows the coordinate of the i-th point.(Xi,Yi)(0≤Xi,Yi≤M).

Output
T lines, each line is “YES” or “NO”.

Sample Input

2
3 10
1 1
2 2
3 3
4 10
8 8
2 3
3 3
4 4

Sample Output

YES
NO

题目分析:

2016HDU多校第三场最后一题。
大意是在一个平面(0,0)到(m,m)中,有n个点,问是否能找到这样的4元组(A,B,C,D),使得A与B的曼哈顿距离等于C与D的曼哈顿距离。(其中A

代码如下:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <set>
using namespace std;

struct sa
{
    int x,y;
}a[100010];
int T;
int n,m;
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        set<int>s;//用set容器存放曼哈顿距离,便于操作
        for(int i=1; i<=n; i++) scanf("%d%d",&a[i].x,&a[i].y);
        if (n*(n-1)>m*2) {printf("YES\n"); continue;}
        bool f=0;
        for(int i=1; i<=n; i++)
        {
            for(int j=i+1; j<=n; j++)
            {
                int x=(abs)(a[i].x-a[j].x)+(abs)(a[i].y-a[j].y);
                if (s.find(x)!=s.end()) f=1;
                s.insert(x);
            }
        }
        if (f) printf("YES\n");
        if (!f) printf("NO\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值