CSU->1018: Avatar

6 篇文章 0 订阅
1 篇文章 0 订阅

1018: Avatar

         Time Limit: 1 Sec     Memory Limit: 128 Mb     

Description

In the planet Pandora, Jake found an old encryption algorithm. The plaintext, key and ciphertext are all four decimal numbers and all greater than 0. The way to get the ciphertext from the plaintext and the key is very simple: the ciphertext is the last four digits of the product of the plaintext and the key (for example: the plaintext is 2010 and the key is 4024, and then the product is 8088240. So the ciphertext is 8240).

Note that the plaintext and the key don’t have leading 0, while the ciphertext might have. Now given the plaintext and the key, you are asked to figure out the ciphertext for Jake quickly.

Input

The first line is an integer T, which presents the number of test cases. Then there are T lines, each line has two integers, the first integer is the plaintext and the second is the key.

Output

For each test case, output the ciphertext.

Sample Input

2
2010 4024
1234 1111

Sample Output

8240
0974

Hint

Source

中南大学第四届大学生程序设计竞赛

题目链接:http://acm.csu.edu.cn/csuoj/problemset/problem?pid=1018

AC代码:

#include<iostream>
using namespace std;

int main(){
    int plaintext, key ,ciphertext;
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&plaintext,&key);
        int res=plaintext*key;
        ciphertext=res%10000;
        printf("%04d\n",ciphertext);
//      if(ciphertext>=1000){
//          printf("%d\n",ciphertext);
//      }
//      else{
//          if(ciphertext>=100){
//              printf("0%d\n",ciphertext);
//          }
//          else if(ciphertext>=10){
//              printf("00%d\n",ciphertext);
//          }
//          else if(ciphertext>=0){
//              printf("000%d\n",ciphertext);
//          }   
//          else{
//              printf("0000\n");
//          }
//      }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值