Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.
Input
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
Output
Sample Input
2 2 1 5 2 4 2 1 5 6 6
Sample Output
11 12
题解:
利用优先队列,按位置首要排序,按可踢出的距离次要排序。注意优先队列的排序定义。代码如下:
#include <iostream>
#include <string>
#include <cstdio>
#include <queue>
using namespace std;
struct node {
int p, d;
bool operator < (const node& u) const{
if (p == u.p) return d > u.d;
else return p > u.p;//return 为true的时候u先出队
}
};
int main()
{
#ifdef _DEBUG
freopen("data.in", "r", stdin);
#endif
int T; scanf("%d", &T);
while (T--) {
priority_queue<node>Q;
int n; scanf("%d", &n);
int a, b;
while (n--) {
scanf("%d%d", &a, &b);
Q.push({ a, b });
}
bool odd = true;
int p, d, ans;
while (!Q.empty()) {
ans = Q.top().p;
if (odd) {
d = Q.top().d;
p = Q.top().p + d;
}
Q.pop();
if (odd) {
Q.push({ p,d });
}
odd = !odd;
}
printf("%d\n", ans);
}
return 0;
}