n 个同学去动物园参观,原本每人都需要买一张门票,但售票处推出了一个优惠活动,一个体重为 xx 的人可以和体重至少为 2x2x 配对,这样两人只需买一张票。现在给出了 nn 个人的体重,请你计算他们最少需要买几张门票?
输入格式
第一行一个整数 nn,表示人数。
第二行 nn 个整数,每个整数 a_iai 表示每个人的体重。
输出格式
一个整数,表示最少需要购买的门票数目。
数据范围
对于 30\%30% 的数据:1 \le n \le 251≤n≤25,1\le a_i \le 1001≤ai≤100。
对于 60\%60% 的数据:1 \le n \le 100001≤n≤10000,1\le a_i \le 10001≤ai≤1000。
对于 100\%100% 的数据:1 \le n \le 5\cdot 10^51≤n≤5⋅105,1\le a_i \le 10^51≤ai≤105。
样例解释
11 和 99 配对,77 和 33 配对,剩下 5,55,5 单独,一共买四张票。
样例输入复制
6 1 9 7 3 5 5
样例输出复制
4
题目来源
题目解答:
今天写的这道题有点意思,x与大于等于2x的数可以合并为一个数,问经过你的操作后,这个数列最后最少可以变成几个数。
首先,如果给你n个数,最极端的情况可以变为n/2个数(n为奇数的话+1) ,我们可以从小到达排列这个数组,越大的数越不能浪费,尽可能的让大的数与其它的数合并,那么从数组中间画一条分界,看分界左边开始的数能否与最末端的数匹配,若能,
ans++,左边下标左移,右边下标左移,如果不能匹配,左边下标左移。如此匹配最优。
代码:
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn=500005;
int a[maxn];
int main()
{
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
sort(a,a+n);
int u;
if(n%2)
u=n/2;
else
u=n/2-1;
int v=n-1;
int mid=u;
int ans=0;
while(u>=0&&v>mid)
{
if(a[u]*2<=a[v])
{
u--;
v--;
ans++;
}
else
{
u--;
ans++;
}
}
if(u>=0)
ans+=u+1;
if(v>=mid)
ans+=v-mid;
//cout << ans << endl;
printf("%d\n",ans);
return 0;
}