poj3278 C - Catch That Cow

原题链接:http://poj.org/problem?id=3278

题面

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17
Sample Output

4

代码一:kuangbin模板

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
#include<math.h>
#include<queue>
using namespace std;
const int maxn=200000;
int dis[maxn];
int vis[maxn];
int n,k;
int bfs()
{
    queue<int> q;
    q.push(n);
    vis[n]=1;
    if(n==k)  return 0;
    while(!q.empty())
    {
        int x=q.front();
        q.pop();
        int nx=x+1,ny=x*2,nz=x-1;
        if(nx==k||ny==k||nz==k)
        return dis[x]+1;
        else
        {
            if(nx<=2*max(k,n)&&nx>=0&&!vis[nx])
            {
                vis[nx]=1;
                q.push(nx);
                dis[nx]=dis[x]+1;
            }
            if(ny<=2*max(k,n)&&ny>=0&&!vis[ny])
            {
                vis[ny]=1;
                q.push(ny);
                dis[ny]=dis[x]+1;
            }
            if(nz<=2*max(k,n)&&nz>=0&&!vis[nz])
            {
                vis[nz]=1;
                q.push(nz);
                dis[nz]=dis[x]+1;
            }
        }
    }
    return -1;
}
int main()
{
    while(cin>>n>>k)
    {
        memset(dis,0,sizeof(dis));
        memset(vis,0,sizeof(vis));
        int res=bfs();
        cout<<res<<endl;
    }
    return 0;
}

代码二:

#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
using namespace std;
 
const int maxn=100001;
 
bool vis[maxn];//标记数组
int step[maxn];//记录到了每一位置所走的步数
queue <int> q;//定义队列
 
int bfs(int n,int k)
{
    int head,next;
    q.push(n);   //开始FJ在n位置,n入队
    step[n]=0;
    vis[n]=true; //标记已访问
    while(!q.empty())  //当队列非空
    {
        head=q.front();  //取队首
        q.pop();         //弹出对首
        for(int i=0;i<3;i++)     //FJ的三种走法
        {
            if(i==0) next=head-1;
            else if(i==1) next=head+1;
            else next=head*2;
            if(next<0 || next>=maxn) continue; //排除出界情况
            if(!vis[next])  //如果next位置未被访问
            {
                q.push(next);    //入队
                step[next]=step[head]+1;  //步数+1
                vis[next]=true;  //标记已访问
            }
            //if(rear>=0&&rear<=100000&&vis[rear]==0)//判断是否越界,并且这一步没有走过 
			//{
			//	vis[rear]=1;//标记这一步走过了 
			//	step[rear]=step[front]+1;// 步数+1 
			//	q.push(rear);//将当前位置压入队列 
			//}
            if(next==k) return step[next];  //当遍历到结果,返回步数
        }
    }
}
int main()
{
    int n,k;
    while(cin>>n>>k)
    {
        memset(step,0,sizeof(step));
        memset(vis,false,sizeof(vis));
        
        while(!q.empty()) q.pop(); //注意调用前要先清空
        if(n>=k) printf("%d\n",n-k);
        else printf("%d\n",bfs(n,k));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值