数据结构 深度优先搜索问题练习 拯救007

06-图2 Saving James Bond - Easy Version (25 point(s))

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

Yes

Sample Input 2:

4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

No

Author: 陈越

Organization: 浙江大学

Time Limit: 400 ms

Memory Limit: 64 MB

Code Size Limit: 16 KB

 

 

题目的意思如上图所示,注意,小岛的半径是7.5,然后直接对坐标点进行深度优先搜索。这里有一个难点是第一步的选择并不是唯一的,所以需要用一个栈/队列,将所有可能的第一步跳跃都存下来,然后遍历所有的可能。在深搜的过程中,只有到达岸边就输出结果,然后终止程序,否则就输出No,这是一个很好的思路

#include<stdio.h>
#include<math.h>
#include<stdlib.h>
#define MAX_NUM 110
struct coordinate
{
	int x;
	int y;
}P[MAX_NUM];

int n;            // 点的总个数
int d;            // 跳的距离
int visited[MAX_NUM];
double Distance(coordinate a, coordinate b);  // 求a和b点的距离
void DFS(int i);                              // 从编号为i点开始深搜

int main()
{
	int tempx,tempy;
	int FirstJump[MAX_NUM];   // 用一个栈来保存第一跳的点的编号,需要对所有第一跳的点进行遍历
	coordinate Origin;
	Origin.x = 0;
	Origin.y = 0;
	int top = -1;
	scanf("%d %d", &n, &d);
	for (int i = 0; i < n; i++)
	{
		scanf("%d %d", &tempx, &tempy);
		P[i].x = tempx;
		P[i].y = tempy;
	}
	for (int i = 0; i < n; i++)
		visited[i] = 0;
	for (int i = 0; i < n; i++)
	{
		// 开始半径是7.5
		if (Distance(P[i], Origin) <= (d+7.5))
		{
			FirstJump[++top] = i;
		}
	}
	

	
	if (top == -1)
	{
		printf("No\n");
		return 0;
	}

	for (int i = 0; i <= top; i++)
	{
		DFS(FirstJump[i]);
	}

	printf("No\n");
	return 0;

}

double Distance(coordinate a, coordinate b)
{
	return sqrt(pow((a.x - b.x), 2) + pow((a.y - b.y), 2));
}
void DFS(int i)
{
	visited[i] = 1;
	if ((50 - abs(P[i].x)) <= d || (50 - abs(P[i].y)) <= d)
	{
		printf("Yes\n");
		exit(0);
	}
	for (int j = 0; j < n; j++)
	{
		if (!visited[j] && Distance(P[i], P[j]) <= d)
		{
			DFS(j);
		}
	}
}

 

  • 2
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值