The Triangle

The Triangle

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
输出
Your program is to write to standard output. The highest sum is written as an integer.
样例输入
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

样例输出

30

题目意思如下:

图1显示了一个数字三角形。编写一个程序,计算从顶部开始到底部某处结束的路由上传递的最高数字总和。每一步都可以向左倾斜或向右倾斜。
内部
您的程序是从标准输入读取。第一行包含一个整数N :三角形中的行数。以下N行描述三角形的数据。三角形中的行数大于1但小于等于100。三角形中的数字(均为整数)介于0和99之间。
作出
您的程序将写入标准输出。最高和被写成整数。

题目详解:该题是用动态规划,若想数值最大则当前层的元素应加上的是当前层的的正上方和左上方最大的数            即a[i][j]+=max(a[i-1][j],a[i-1][j]),其中a[i][j]的值就是到第i层第j列的最大数,然后在分别比较该层的所有数得到最大值   if(a[i][j]>m)   m=a[i][j];     则m即为所求。

# include<stdio.h>
int a[1005][1005];
int cmp(int a,int b)
{
	if(a<b) return b;
	return a;
}
int main(){
	int n;
	scanf("%d",&n);
 for(int i=1;i<=n;i++)
	for(int j=1;j<=i;j++)
	scanf("%d",&a[i][j]);
	int max=0;
	for(int i=1;i<=n;i++)
	for(int j=1;j<=i;j++)
	{
	a[i][j]+=cmp(a[i-1][j],a[i-1][j-1]);	
		if(a[i][j]>max)
		max=a[i][j];
	}
	printf("%d\n",max);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值