A+B Problem II

A+B Problem II

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


解题思路:该题主要是用字符串代替数字,进行运算

代码如下:

# include<stdio.h>
# include<string.h>
int main(){
	int t;
	scanf("%d",&t);
	getchar();
	int k=1;
	while(t--)
	{  int l=0;
	char a[1005],b[1005];
	int d[1005];	
		scanf("%s%s",a,b);
		printf("Case %d:\n",k++);
		printf("%s + %s = ",a,b);
		int i=strlen(a)-1,j=strlen(b)-1,c=0;
		while(i>=0&&j>=0)
		{   int c1=a[i]-'0';
		int c2=b[j]-'0';
			d[l++]=(c+c1+c2)%10;
			c=(c+c1+c2)/10;	   //c表示进位 
			i--;j--;		
		}
		while(i>=0)             //两个数不一定位数相同 
		{
			int c1=a[i]-'0';
            d[l++]=(c+c1)%10;
            c=(c+c1)/10;
			i--;
		}
		while(j>=0)
		{
			int c1=b[j]-'0';
            d[l++]=(c+c1)%10;
            c=(c+c1)/10;
			j--;
		}
		l--;
		if(c!=0) printf("%d",c);  //防止当i,j都是0时,有进位,如11+99,此时c为1 
		for(l;l>=0;l--)
		printf("%d",d[l]);
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值