nyoj 推桌子

推桌子

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.
输入
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 
line, the remaining test cases are listed in the same manner as above.
输出
The output should contain the minimum time in minutes to complete the moving, one per line.
样例输入
3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50
样例输出
10
20
30

题目分析:该题大概的意思是有两排房间,中间有一个走廊,如果在同列,不能同时推如(1 ,3)和(4,6),可以将他们都变成同一行(将房间数+1然后再除以2)。还有如果想要从房间 i 推到 房间 j,如(1 , 2)和(5,6)因为房间不相接,可以同时推(不是一个人在推,不共用一段走廊,若共用一段走廊这不能同时推)

该题还有一个细节,他没规定前一个房间号码一定大于后一个,

代码如下:

# include<stdio.h>
# include<algorithm>
using namespace std;
struct node{
	int end;
	int begin;
}a[205];
bool cmp(node a,node b)
{
	if(a.begin==b.begin)
	return a.end<b.end;
	return a.begin<b.begin;
}
int main(){
	
	int t;
	scanf("%d",&t);
	while(t--)
	{
	int n;	
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d %d",&a[i].begin,&a[i].end);
			a[i].begin=(a[i].begin+1)/2;           //将两行变成一行 
			a[i].end=(a[i].end+1 )/2; 
			if(a[i].begin>a[i].end)
			{
				int k=a[i].begin;
				a[i].begin=a[i].end;
				a[i].end=k;
			}
		}
		sort(a,a+n,cmp);
		int k=0;
		int c2=a[0].end;
		for(int j=0;j<n;j++)
		{
			int kk=0;
			c2=-1;
		for(int i=0;i<n;i++)
		{   
			if(a[i].begin!=-1)
			{
				if(a[i].begin>c2)
				{
				a[i].begin=-1;	
				kk=1;
				c2=a[i].end;	
				}
			}			
		}
			if(kk) k++;
			else break;			
		}
		printf("%d\n",k*10);
	}
	
	return 0;
} 

1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看REAdMe.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看REAdMe.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看READme.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值