Sorting It All Out

Sorting It All Out

时间限制: 3 Sec   内存限制: 64 MB

题目描述

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

输入

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

输出

For each problem instance, output consists of one line. This line should be one of the following three: Sorted sequence determined after xxx relations: yyy...y. Sorted sequence cannot be determined. Inconsistency found after xxx relations. where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

样例输入

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

样例输出

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

解题思路:拓扑排序;

代码如下:

# include<stdio.h>
# include<string.h>
# include<queue>
using namespace std;
int map[30][30],a[30],count1[30];
int n,m,k1,k2;
int topusort()
{  
priority_queue<int,vector<int>,greater<int> >q; 
int count[30];
for(int i=0;i<n;i++)
{
	count[i]=count1[i];
	if(!count[i])         //找出入度为0的点,作为起始点 
	q.push(i);
}
    int k=0;  //观察去掉的节点数量,若k 最后不等于n,说明有环 
	int k4=0;
	while(!q.empty())
	{
		if(q.size()>1) 
		{
			k4=1;    //观察入度个数,如果入度大于1,说明无法判断大小 
		}
	   int t=q.top();	
		q.pop();
		a[k++]=t;
		for(int i=0;i<n;i++)
		{
			if(map[t][i])
			{
		        count[i]--;	
		       if(!count[i])	
			   q.push(i);
			}
		}
		
	}
	if(k!=n) return 1;   
	if(k4==1) return 0;
	return -1;   //说明成功 
}

int main(){
	while(~scanf("%d%d",&n,&m)&&n&&m)
	{    
	     k1=0;
		 k2=0;
		 int step;
		memset(map,0,sizeof(map));
		memset(count1,0,sizeof(count1));
		char c[3];
		for(int i=1;i<=m;i++)
		{
			scanf("%s",c);
		
			if(!k1&&!k2)
			{
				if(map[c[2]-'A'][c[0]-'A'])   //判断是不是有环 
				{   
					k2=1;
					printf("Inconsistency found after %d relations.\n",i);
					continue;
				}
				if(!map[c[0]-'A'][c[2]-'A'])
				{
				map[c[0]-'A'][c[2]-'A']=1;	
				count1[c[2]-'A']++;		 //保存入度				
				}	
				int k=topusort();  //进行拓扑排序 
				if(k==1)
				{
				k2=1;
				printf("Inconsistency found after %d relations.\n",i);	
				}	
				else if(k==-1)
				{
					step=i;
					k1=1;
						}		
			}
		}	
		if(k1==0&&k2==0)
		printf("Sorted sequence cannot be determined.\n");
		else if(k1==1)
		{
		printf("Sorted sequence determined after %d relations: ", step);
		for(int i=0;i<n;i++)	
			printf("%c",a[i]+'A');
			printf(".\n");
		}		
	}	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值