PAT甲级 1038

1038 Recover the Smallest Number (30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

 题意: 首先给出一个数字n,然后是n个数字段,要求输出n个数字段组成的最小数,同时,若第一位是零则舍去

解题思想:对给定的数段进行逐渐两两相加的比较,每一次比较都能得出一个暂时的最小数,重复下去,直到将所有的数段都加进去。同时设定一个标志flag,代表最小数的首位是否为0,若为零,则mark++,从下一位开始取值。

#include<iostream>
#include<bits/stdc++.h>
#define long 10000000
using namespace std;
string s[10005];
bool cmp(string x,string y)
{
    return x+y<y+x;
}
int main()
{
    int n;
    cin>>n;
    for(int i=0; i<n; i++)
    {
        cin>>s[i];
    }
    sort(s,s+n,cmp);
    int flag=0;
    for(int i=0; i<n; i++)
    {
        if(flag==0)//判断首位是否为零,若为零,则Mark++,j从下一位开始取
        {
            int mark=0;
            while(s[i][mark]=='0')
            {
                mark++;
            }

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值