PAT-A1140/B1084 Look-and-say Sequence/外观数列 题目内容及题解

Look-and-say sequence is a sequence of integers as the following:

外观数列是指具有以下特点的整数序列:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D (corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

它从不等于 1 的数字 d 开始,序列的第 n+1 项是对第 n 项的描述。比如第 2 项表示第 1 项有 1 个 d,所以就是 d1;第 2 项是 1 个 d(对应 d1)和 1 个 1(对应 11),所以第 3 项就是 d111。又比如第 4 项是 d113,其描述就是 1 个 d,2 个 1,1 个 3,所以下一项就是 d11231。当然这个定义对 d = 1 也成立。本题要求你推算任意给定数字 d 的外观数列的第 N 项。

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

输入第一行给出 [0,9] 范围内的一个整数 d、以及一个正整数 N(≤ 40),用空格分隔。

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

在一行中给出数字 d 的外观数列的第 N 项。

Sample Input:

1 8

Sample Output:

1123123111

解题思路

  1. 读入初始数字和重复趟数并将初始数字压入vector容器Look;
  2. 重复若干次以下流程:模拟看的过程(读取当前数字,数数,将其转化为单个数字并加入Say序列)并将look容器的内容替换为当前Say容器;
  3. 按照题目要求输出Look容器的内容并返回零值。

代码

#include<cstdio>
#include<vector>
using namespace std;

vector<int>Look,Say;

void Op(){
    int now=Look[0],i=0,num=0;
    int n[50],k=0;
    Say.clear();
    while(i<Look.size()){
        Say.push_back(now);
        while(i<Look.size()&&Look[i]==now){
            i++,num++;
        }
        k=0;
        while(num){
            n[k++]=num%10;
            num/=10;
        }
        while(k--){
            Say.push_back(n[k]);
        }
        if(i<Look.size()){
            now=Look[i];
            num=0;
        }
    }
    Look=Say;
}

int main(){
    int i,a,N;
    scanf("%d%d",&a,&N);
    Look.push_back(a);
    while(--N){
        Op();
    }
    for(i=0;i<Look.size();i++){
        printf("%d",Look[i]);
    }
    printf("\n");
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值