简谈--贪心算法

所谓贪心算法是指:在对问题求解时,总是作出在当前看来是最好的选择。也就是说,不从整体上加以考虑,它所作出的仅仅是在某种意义上的局部最优解(是否是全局最优,需要证明)。在对问题求解时,总是作出在当前看来是最好的选择。也就是说,不从整体上加以考虑,它所作出的仅仅是在某种意义上的局部最优解(是否是全局最优,需要证明)。

特别说明:若要用贪心算法求解某问题的整体最优解,必须首先证明贪心思想在该问题的应用结果就是最优解!!

用事实说话——实 例 分 析

一、事件序列问题

已知N个事件的发生时刻和结束时刻(见下表,表中事件已按结束时刻升序排序)。一些在时间上没有重叠的事件,可以构成一个事件序列,如事件

{2,8,10}。事件序列包含的事件数目,称为该事件序列的长度。请编程找出一个最长的事件序列。

事件编号

0

1

2

3

4

5

6

7

8

9

10

11

发生时刻

1

3

0

3

2

5

6

4

10

8

15

15

结束时刻

3

4

7

8

9

10

12

14

15

18

19

20

算法分析:

l不妨用Begin[i]和End[i]表示事件i的开始时刻和结束时刻。则原题的要求就是找一个最长的序列a1<a2<…<an,满足:

Begin[a1]<End[a1]<=…<=Begin[an]<End[an]。

可以证明,如果在可能的事件a1<a2<<an中选取在时间上不重叠的最长序列,那么一定存在一个包含a1(结束最早)的最长序列。

二、区间覆盖问题

用i来表示x轴上坐标为[i-1,i]的区间(长度为1),并给出M(1=<M=<200)个不同的整数,表示M个这样的区间。现在让你画几条线段覆盖住所有的区间,条件是:每条线段可以任意长,但是要求所画线段之和最小,并且线段的数目不超过N(1=<N=<50)。

例如:M=5个整数1、3、4、8和11表示区间,要求所用线段不超过N=3条

0     1     2   3     4      5     6      7       8      9     10     11

算法分析:

l如果N>=M,那么显然用M条长度为1的线段可以覆盖住所有的区间,所求的线段总长为M。
l如果N=1,那么显然所需线段总长为:…
l如果N=2,相当于N=1的情况下从某处断开(从哪儿断开呢?)。
l如果N=k呢?

三、 HD OJ_1050  MovingTables

Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output
The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input
  
  
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50

Sample Output
  
  
10 20 30
算法分析:

1、如果没有交叉,总时间应该是多少?

2、影响搬运时间的因素是什么?

3、如果每趟处理都包含最大重叠,处理后   的效果是什么?

4、得出什么结论?

下面给出参考代码:

·

#include <iostream>

using namespace std;

int main()

{ intt,i,j,N,P[200];

   ints,d,temp,k,min;

   cin>>t;

   for(i=0;i<t;i++)

      {

         for(j=0;j<200;j++)

              P[j]=0;

         cin>>N;

        for(j=0;j<N;j++)

            {

               cin>>s>>d;

               s=(s-1)/2;

               d=(d-1)/2;       

if(s>d)

                 { temp=s;

                    s=d;

                    d=temp; }

              for(k=s;k<=d;k++)

                 P[k]++;

            }

         min=-1;

        for(j=0;j<200;j++)

           if(P[j]>min)

              min=P[j];

         cout<<min*10<<endl;

      }

   return 0;


总结: 贪心算法的基本步骤:

1、从问题的某个初始解出发。

2、采用循环语句,当可以向求解目标前进一步时,就根据局部最优策略,得到一个部分解,缩小问题的范围或规模。

3、将所有部分解综合起来,得到问题的最终解。


到此结束,see you next time!!


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值