题目链接:http://poj.org/problem?id=3320
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 13611 | Accepted: 4670 |
Description
Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.
A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.
Input
The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.
Output
Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.
Sample Input
5 1 8 8 8 1
Sample Output
2
题目大意:
XXX要准备考试,书总共有P页,第i页恰好有一个知识点ai,书中的同一个知识点可能会被多次提到,所以他希望看其中连续的一些页的书来把所有的知识点都给看完。。
题目分析:
其实页数可以看作连续的序列,然后就是要求出一个子序列,子序列的要求的包涵所有知识点都有的页数,且子序列的长度要最短。
首先我们并不知道总共有多少个知识点,这是个先要记录的。
不断的把序列中的元素加入到子序列中,知识点的数目会不断的增加,当知识点是数目满了之后,把子序列前面的元素开始剔除,再看看现在的子序列还是否满足这个条件。满足继续删除子序列前面的元素,否则的话把后面的元素加入到子序列中。
注意中间过程知识点数的增加或减少的维护。
代码:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
#include <map>
#include <set>
#include <vector>
using namespace std;
typedef long long LL;
const int N=100000+999;
int n,m;
int num[N];
//尺取法
int main()
{
while(scanf("%d",&n)!=EOF)
{
memset(num,0,sizeof(num));
set<int> all; //利用集合元素的单一性
map<int,int> cot;
for(int i=0; i<n; i++)
{
scanf("%d",&num[i]);
all.insert(num[i]);
}
int res=n;
m=all.size(); //算出种类
int s=0,e=0,sum=0;
while(1)
{
while(e<n && sum<m)
{
if(cot[ num[e++] ]++ == 0) //如果这个种类未出现 则sum++
sum++;
}
if(sum<m) break;
res=min(res,e-s);
if(--cot[ num[s++] ] == 0) //如果这个种类-1后为0 则sum-1
sum--;
}
printf("%d\n",res);
}
return 0;
}