动态规划----Human Gene Functions(POJ 1080)

POJ 1080-----Human Gene Functions

Problem Description
It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned:

AGTGAT-G
-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

* denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.
 

Output
The output should print the similarity of each test case, one per line.
 

Sample Input
   
   
2 7 AGTGATG 5 GTTAG 7 AGCTATT 9 AGCTTTAAA
 

Sample Output
   
   
14 21
解题思路:(与《算法导论》十五章中求解最长公共序列思路基本相同)

设两个基因串为Xm, Yn 设Xm, Yn的相似程度为c[m, n] 它的子问题为Xi, Yj相比较,其相似程度为c[i, j] 若xi与yj相比较,则c[i, j]=c[i-1, j-1]+value[xi, yj] 若xi与'-'相比较,则c[i, j]=c[i-1, j]+value[xi, '-'] 若'-'与yj相比较,则c[i, j]=c[i, j-1]+value['-', yj] c[i, j]=max{c[i-1, j-1]+value[xi, yj], c[i-1, j]+value[xi, '-'], c[i, j-1]+value['-', yj]} 边界条件:c[0, 0]=0, c[i, 0]=c[i-1, 0]+value[xi, '-'], c[0, j]=c[0, j-1]+value['-', yj]

以下为代码:
#include <iostream>
#include <string>
#include <vector>

using namespace std;

int nValue[5][5]={
      {5, -1, -2, -1, -3},
      {-1, 5, -3, -2, -4},
      {-2, -3, 5, -2, -2},
      {-1, -2, -2, 5, -1},
      {-3, -4, -2, -1, INT_MIN} };

int Translate(char ch)
{
      switch(ch)
      {
      case 'A': return 0;
      case 'C': return 1;
      case 'G': return 2;
      case 'T': return 3;
      default: return 4;
      }
}

int main()
{
      int nTest;
	  int t,i,j;
      string strSeqX, strSeqY;

      cin>>nTest;
      for (t=0; t<nTest; t++)
      {
            int m, n, nCost[101][101];

            cin>>m>>strSeqX>>n>>strSeqY;
            nCost[0][0]=0;
            for (i=0; i<m; i++) nCost[i+1][0]=nCost[i][0]+nValue[Translate(strSeqX[i])][Translate('-')];
            for (j=0; j<n; j++) nCost[0][j+1]=nCost[0][j]+nValue[Translate('-')][Translate(strSeqY[j])];
            for (i=0; i<m; i++)
            {
                  for (j=0; j<n; j++)
                  {
                        int nTmp;

                        nCost[i+1][j+1]=nCost[i][j]+nValue[Translate(strSeqX[i])][Translate(strSeqY[j])];
                        if ((nTmp=nCost[i][j+1]+nValue[Translate(strSeqX[i])][Translate('-')])>nCost[i+1][j+1]) nCost[i+1][j+1]=nTmp;
                        if ((nTmp=nCost[i+1][j]+nValue[Translate('-')][Translate(strSeqY[j])])>nCost[i+1][j+1]) nCost[i+1][j+1]=nTmp;
                  }
            }
            cout<<nCost[m][n]<<endl;
      }
      return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ - 3616是一个题目,题目描述如下: 给定一组区间,每个区间有一个权重,要求选择一些区间,使得这些区间的右端点都小于等于k,并且权重之和最大。请问最大的权重和是多少? 解决这个问题的思路是使用动态规划。首先,将区间按照左端点从小到大进行排序。然后,定义一个dp数组,dp[i]表示右端点小于等于i的所有区间所能得到的最大权重。 接下来,遍历每一个区间,对于每个区间i,将dp[i]初始化为区间i的权重。然后,再遍历i之前的每个区间j,如果区间j的右端点小于等于k,并且区间j的权重加上区间i的权重大于dp[i],则更新dp[i]为dp[j]加上区间i的权重。 最后,遍历整个dp数组,找到最大的权重和,即为所求的答案。 下面是具体的代码实现: ```cpp #include <cstdio> #include <cstring> #include <algorithm> using namespace std; struct interval{ int start, end, weight; }; interval intervals[10005]; int dp[10005]; int n, m, k; bool compare(interval a, interval b) { if (a.start == b.start) { return a.end < b.end; } else { return a.start < b.start; } } int main() { while(~scanf("%d %d %d", &n, &m, &k)) { memset(dp, 0, sizeof dp); for (int i = 0; i < m; i++) { scanf("%d %d %d", &intervals[i].start, &intervals[i].end, &intervals[i].weight); } sort(intervals, intervals + m, compare); for (int i = 0; i < m; i++) { dp[i] = intervals[i].weight; for (int j = 0; j < i; j++) { if (intervals[j].end <= k && dp[j] + intervals[i].weight > dp[i]) { dp[i] = dp[j] + intervals[i].weight; } } } int maxWeight = 0; for (int i = 0; i < m; i++) { maxWeight = max(maxWeight, dp[i]); } printf("%d\n", maxWeight); } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值