【POJ】2506 - Tiling(递推,高精度)

41 篇文章 0 订阅
19 篇文章 0 订阅

Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8687 Accepted: 4183

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source



看到n的取值范围,直接懵了。然后就学了高精度,感觉好棒。

代码如下:

#include <cstdio>
int main()
{
	int f[300][100];
	f[0][0] = 1;		//至于这里为什么是1,本人表示不理解,2 * 0 的格子难道不是 0 种方案吗 
	f[1][0] = 1;
	f[2][0] = 3;
	for (int i = 3 ; i <= 250 ; i++)
	{
		int t = 0;
		for (int j = 0 ; j <= 99 ; j++)
		{
			t += f[i-1][j] + f[i-2][j] * 2;
			f[i][j] = t % 10;
			t /= 10;
		}
	}
	int n;
	while (~scanf ("%d",&n))
	{
		int tt;
		for (tt = 99 ; tt >= 0 ;tt--)
		{
			if (f[n][tt] != 0)
				break;
		}
		for (;tt >= 0 ; tt--)
			printf ("%d",f[n][tt]);
		printf ("\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值