【HDU】1757 - A Simple Math Problem(矩阵构造方法 & 快速幂)

13 篇文章 0 订阅
12 篇文章 0 订阅

点击打开题目

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4161    Accepted Submission(s): 2506


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
  
  
45 104
 

Author
linle
 

Source
 



矩阵快速幂已经基本掌握了,然后就是矩阵构造的问题,由于没有学过线性代数,网上的教程好多都看不懂。

但是我差不多总结出来一个基本思路,先做一个 1 * n 的矩阵 A ,它表示递推式中的关系(不含系数)。

然后再构造一个矩阵 B 表示结果的矩阵,这个矩阵中就是把上一个矩阵的 n 变为 n+1 。

然后找出一个中间矩阵 C (n * n)使 A * C == B。


然后根据矩阵的结合律(实际上我不知道这个结合律怎么用)得出   A * C^ ( n - x ) == B             这个 x 的具体数值根据矩阵直接的关系观察得到。





然后是这道题,用刚刚的方法:(画矩阵好难啊 T^T)我找个网站吧,跟我分析的方法总体思路差不多。

传送门:点击打开链接


然后加上一个矩阵快速幂就行了。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define MAX 10
#define CLR(a,b) memset(a,b,sizeof(a))
int a[11];
__int64 MOD;
struct Matrix
{
	__int64 m[MAX+5][MAX+5];
	int w,h;
}pr,res,ori;
void init()
{
	pr.w = pr.h = 10;		//构造10*10的矩阵
	CLR(pr.m,0);
	for (int i = 1 ; i <= 10 ; i++)
		pr.m[i][1] = a[i-1];
	for (int i = 1 ; i <= 9 ; i++) 		//从第1行到第九行构造初始矩阵
		pr.m[i][i+1] = 1;
	res.h = 10;		//构造单位矩阵
	res.w = 10;
	CLR(res.m,0);
	for (int i = 1 ; i <= 10 ; i++)
		res.m[i][i] = 1;
}
Matrix Matrix_multiply(Matrix x,Matrix y)
{
	Matrix t;
	t.h = x.h;
	t.w = y.w;
	CLR(t.m,0);
	for (int i = 1 ; i <= x.h ; i++)
	{
		for (int j = 1 ; j <= x.w ; j++)
		{
			if (x.m[i][j] == 0)
				continue;
			for (int k = 1 ; k <= y.w ; k++)
				t.m[i][k] = (t.m[i][k] + x.m[i][j] * y.m[j][k] % MOD) % MOD;
		}
	}
	return t;
}
void Matrix_mod(int n)		//矩阵快速幂 
{
	while (n)
	{
		if (n & 1)
			res = Matrix_multiply(res , pr);
		pr = Matrix_multiply(pr , pr);
		n >>= 1;
	}
}
int main()
{
	int n;
	ori.w = 10;
	ori.h = 1;
	for (int i = 1 ; i <= 10 ; i++)
		ori.m[1][i] = (10 - i);
	while (~scanf ("%d %I64d",&n,&MOD))
	{
		for (int i = 0 ; i < 10 ; i++)
			scanf ("%d",&a[i]);
		if (n < 10)
		{
			printf ("%d\n",n);
			continue;
		}
		init();
		Matrix_mod(n - 9);
		res = Matrix_multiply(ori , res);		//要注意矩阵乘法没有交换律
		printf ("%I64d\n",res.m[1][1]);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值