POJ 3070 Fibonacci

Fibonacci

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:Description

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

 

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
using namespace std;
const int MOD = 10000;

struct matrix{
    int m[2][2];
}ans;

matrix base = {1,1,1,0};

matrix mat_mutil(matrix a, matrix b){
    matrix tmp;
    for(int i=0;i<2;i++){
        for(int j=0;j<2;j++){
            tmp.m[i][j] = 0;
            for(int k=0;k<2;k++){
                tmp.m[i][j] = (tmp.m[i][j] + a.m[i][k] * b.m[k][j])%MOD;
            }
        }
    }
    return tmp;
}

int matrix_pow(matrix a, int b){
    ans.m[0][0] = ans.m[1][1] = 1;
    ans.m[0][1] = ans.m[1][0] = 0;
    while(b){
        if(b&1){
            ans = mat_mutil(ans,a);
        }
        a = mat_mutil(a,a);
        b >>= 1;
    }
    return ans.m[0][1];
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF){
        if(n==-1){
            break;
        }
        else{
            printf("%d\n",matrix_pow(base,n));
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Loganer

感谢

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值