hd2277

Change the ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Garfield has three piles of balls, each pile has unique color of following: yellow, blue, and red. Now we also know Garfield has Y yellow balls, B blue balls, and R red balls. But Garfield just wants to change all the balls to one color. When he puts two balls of different color togather, the balls then change their colors automatically into the rest color. For instance, when Garfield puts a red one and a yellow one togather, the two balls immediately owns blue color, the same to other situations. But the rule doesn’t work when the two balls have the same color.
  Garfield is not able to estimate the minimal steps to achieve the aim. Can you tell him?

 Input
For each line, there are three intergers Y, B, R(1<=Y,B,R<=1000),indicate the number refered above.
 
Output
For each case, tell Garfield the minimal steps to complete the assignment. If not, output the symbol “):”.
 
Sample Input
  
  
1 2 3 1 2 2
 
Sample Output
  
  
): 2
恩,题目大意就是说黄色,蓝色,红色三种颜色的气球分别为y,b,r个,然后任意两个不同颜色的球放一起都会变成剩下的那一种颜色,现在呢出题人十分无聊的想要把所有的气球都变为一种颜色,问能否实现,若不能输出哭脸,若能输出最小次数。
恩,规律题,不会做,没找对规律。经过大神学长讲了之后才懂,若三个数有一个比另外一个大3的倍数就一定能实现。
然后我是每次都把气球往最少的那种颜色去,然后就没有然后了。。。。。
#include<stdio.h>
#include<algorithm>
int a[4];
int mm()
{
	if((a[1]-a[0])%3==0||(a[2]-a[1])%3==0||(a[2]-a[0])%3==0)	return 1;
	return 0;
}
using namespace std;
int main()
{
	int i,c;
	while(~scanf("%d%d%d",&a[0],&a[1],&a[2]))
	{
		c=0;
		sort(a,a+3);
		if(!mm())printf("):\n");
		else 
		{
			while(a[0]!=a[1]&&a[1]!=a[2]&&a[0]!=a[2])
			{
				a[0]+=2;
				a[1]--;
				a[2]--;
				c++;
				sort(a,a+3);
			}
			if(a[0]==a[1])c+=a[0];
			else if(a[1]==a[2])c+=a[1];
			printf("%d\n",c);
		}
	}
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值