poj 2752 Seek the Name, Seek the Fame

Seek the Name, Seek the Fame
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14092 Accepted: 7009

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5
嗯,题目大一就是说,求字符串中也是后缀的前缀的长度,从小到大排列。
首先它本身就是,然后听说next[lens]记录的就是除去它本身的最长的也是后缀的前缀,然后以此时的状态继续如此,就是递归。我是先把字符串的next数组求出来之前输出然后和测试数据比对的,汗,不是什么好方法。哦,这里只能用next数组,nextval数组会丢失一些数据,渣渣我也不懂。。。
#include<cstdio>
#include<cstring>
#define len 1000000+10
char str[len];
int lens,next[len],rec[len];
void getnext()
{
	int i=0,j=-1;
	next[i]=j;
	while(i<lens)
	{
		if(j==-1||str[i]==str[j])
		{
			i++;
			j++;
			next[i]=j;
		}
		else 
			j=next[j];
	}
}
int main()
{
	while(~scanf("%s",str))
	{
		lens=strlen(str);
		getnext();
		rec[0]=lens;
		int i=1;
		while(next[lens]!=0)
		{
			rec[i++]=next[lens];
			lens=next[lens];
		}
		for(int j=i-1;j>0;j--)
			printf("%d ",rec[j]);
		printf("%d\n",rec[0]);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值